MICROCHIP AN4511

Getting Started with the PIC32CM LE0O/LS00/LS60
Curiosity Pro Board

Abstract

This document aims at getting started with the Microchip® PIC32CM LE00/LS00/LS60 Arm® Cortex®-M23 based
microcontrollers using their respective Curiosity Pro evaluation kits.

The PIC32CM LEOO/LS00/LS60 Curiosity Pro evaluation kits are hardware platforms used to evaluate the
PIC32CM5164LE00100, PIC32CM5164LS00100, and PIC32CM5164LS60100 microcontrollers.

Each kit is supported by the MPLAB® X Integrated Development Environment (MPLAB X IDE) and provides an easy
access to the microcontroller’s features.
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Obtaining the PIC32CM LEOO/LS00/LS60 Curiosity Pro Evaluation Kit

The PIC32CM LEOO, PIC32CM LS00, and PIC32CM LS60 Curiosity Pro evaluation kits are hardware platforms for
evaluating the PIC32CM LEOO/LS00/LS60 microcontrollers (MCUs). Each evaluation kit is supported by the MPLAB
X IDE and MPLAB Harmony v3, featuring application examples.

The Curiosity Pro evaluation kits include an on-board embedded debugger to program or debug the target
microcontroller. This enables an easy start to a project, and provides application examples that can be used in
the design of a custom application.

The Curiosity Pro evaluation kits provide easy access to the features of the microcontroller, and are integrated
with Arduino Uno, mikroBUS™, and extension headers to interface with Xplained Pro extension boards for a rapid
prototyping and expanded functionality.

Figure 1-1. PIC32CM LE00/LS00/LS60 Curiosity Pro Board

The PIC32CM LEOO/LS00/LS60 boards can be purchased at Microchip Direct.
For additional information on the PIC32CM LEO0O0/LS00/LS60 boards and devices, refer these documents:

» PIC32CM LEOO/LS00/LS60 Family Data Sheet (DS60001615)

» PIC32CM LEQOO/LS00/LS60 Family Silicon Errata and Data Sheet Clarifications (DS80000906)
+ PIC32CM LEOO/LS00/LS60 Curiosity Pro User Guide (DS70005443)

» PIC32CM LEOO/LS00/LS60 Curiosity Pro Board Change Notification (DS70005491)
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2. Tools and Software

21 MPLAB X Integrated Development Environment

The MPLAB X Integrated Development Environment (IDE) is an expandable, highly configurable software program
that incorporates powerful tools to discover, configure, develop, debug, and qualify embedded designs for most of
the Microchip’s microcontrollers and digital signals controllers. MPLAB X IDE works seamlessly with the MPLAB
development ecosystem of software and tools.

Figure 2-1. MPLAB X IDE Icon

X IDE
-

Users can download MPLAB X IDE from the Microchip’s website: www.microchip.com/mplab/mplab-x-ide.
Installing PIC32CM LEOO and PIC32CM LS00/LS60 Device Family Packs (DFP)
Follow these steps to install the PIC32CM LEOO and PIC32CM LS00/LS60 DFP:

1. Open MPLAB X IDE.
2. Goto Tools > Packs.
3. Install the PIC32CM LEOO and the PIC32CM LS00/LS60 DFP:

a. Toinstall the PIC32CM LEOO DFP, enter PIC32CM-LE in the DFP Search box to the right, and then install
the latest DFP available.

b. To install the PIC32CM LS00/LS60 DFP, enter PIC32CM-LS in the DFP Search box to the right, and then
install the latest DFP available.
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2.2 MPLAB Code Configurator

The MPLAB Code Configurator (MCC) is a free graphical programming environment that generates seamless, easy-
to-understand C code to insert into projects. Using an intuitive interface, MCC enables and configures a rich set of
peripherals and functions. MCC supports 8-bit, 16-bit, 32-bit PIC®, and SAM® microcontrollers. MCC is incorporated

into MPLAB X IDE as a plugin.
Figure 2-2. MPLAB Code Configurator Icon

Installing MCC from MPLAB X IDE

MPLAB

C OD E

CONFIGURATOR

.

Follow these steps to install MCC from MPLAB X IDE:

1. From the Toolbar, select Tools > Plugins.
Figure 2-3. MPLAB X IDE Plugins Tool

Tools Window Help
Analysis
Embedded
Licenses
Packs
Apply Diff Patch...
Diff
Add to Favorites

Templates
DTDs and XML Schemas

Plugins

Plugins Download

Options

2. In the Plugins window, click the Available Plugins tab and type MCC in the search box. The MCC plugin

details will be displayed (if not yet installed) as shown in the figure 2-4.

3. Select the checkbox next to the MCC plugin, and then click Install.

© 2022 Microchip Technology Inc.
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Figure 2-4. MPLAB Code Configurator Installation from MPLAB X IDE Plugins

B3 Plugins X

Updates | Available Plugins (1/38) | Downloaded Installed (184) Settings

— e Cra—

Install Name Category Source |l

MPLAB® Code Configurator MPLAB IDE nr

MPLAB® Code Configurator
iy Community Contributed Plugin ~

Version: 5.0.3

Author: Microchip Technology Inc

Date: 10/11/21

Source: Microchip Plugins

I page: http://www microchip.com fmec

1 plugin selected, 1678

Close Help

4. In the Plugin Installer window, follow the instructions, and then select Restart Now, and then click Finish
when installation is completed.
5.  MPLAB X IDE will restart with the MCC plugin installed.
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MPLAB Harmony v3

MPLAB Harmony v3 is a fully integrated embedded software development framework that provides flexible and
interoperable software modules to simplify the development of value-added features, and reduce the customer’s time
to market.

Figure 2-5. MPLAB Harmony v3 Icon

MPLAB

HARMONY
=

Go to the Microchip GitHub page https://github.com/Microchip-MPLAB-Harmony to download the following PIC32CM
LEQO/LS00/LS60 application packages:

* csp_apps_pic32cm_le_ls: Contains driver, FS, system service, and RTOS application examples for the
PIC32CM LEOO/LS00/LS60 family.

+ core_apps_pic32cm_le_ls: Contains Peripheral Library (PLIB) application examples for the PIC32CM LEOO/
LS00/LS60 family.

Note: Users can download specific examples from the Microchip website: https://mplab-discover.microchip.com/.

Create a folder and name it as C: \H3, which is used as the MPLAB Harmony v3 framework folder. Unzip application
packages files in this folder as shown in the following figure:

Figure 2-6. Application Packages Unzipped in Harmony v3 Framework

» This PC » Local Disk (C) » H3

Name

core_apps_pic32cm_le_Is

csp_apps_pic32cm_le_ls

Note: The MCC'’s Content Manager can then be used to update the MPLAB Harmony v3 framework folder or
download new packages.
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Follow these steps to define the MPLAB Harmony v3 framework folder in MPLAB X IDE:

1. From the Toolbar, select Options > Plugins.
2. Choose MPLAB Code Configurator 5.x tab.

3. For the Harmony Content Path, choose the created 13 folder as shown in the following figure.

Figure 2-7. MCC Harmony Content Path Update

gOptions
&y i, = q
2k & » L E |0 E

General Editor Fonts & Colors Keymap Embedded Team AppearanceIPIuginsIMisceIIaneous

MPLAB® Harmony Configurator 3 | MPLAB® Code Configurator 5.x )

File Handling Remove unused files from the project
Delete unused files from the disk

Generated Line Endings | DOS (CRLF)

Editor Behavior Always ask before remaoving a madule
[] Always ask before remaving & pin

Autosave MCC configuration file

Libraries RS5 Feed Enable RSS Feed for new library versions {needs IDE restart)
Enter new RSS Feed URL |https://www.microchip.com/mcc_libraries_xml

Restore default RSS Feed

x

Q, |Filter (Ctrl+F)

I Harmony Content Path | C:\H3

1L

[] Always ask for Harmony Content Path when opening project

Install Core Remove Core Open Core Folder
Install Library Remave Library Open Library Folder Reset Plugin Files
Export... Import... I ok J§ Gecv |

Cancel Help

Note: This step is optional for running an application only, but it must be completed to run the MCC plugin.

Users can define another path and name for the Harmony v3 Framework folder, but must ensure to define them as

small as possible for tool restrictions.
Note: The C:\H3 folder will be referenced in this document, from this point forward.

© 2022 Microchip Technology Inc. Application Note
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MPLAB Discover

MPLAB Discover is a catalog of fully configured and complete source codes, projects, examples and software
applications for PIC® and AVR® microcontrollers to help jump-start next customer project. It features intuitive and
powerful search capabilities to search for content quickly and easily.

Figure 2-8. MPLAB Discover Icon

DISCOVER
=

For additional information about MPLAB Discover, go to Microchip website: mplab-discover.microchip.com/.
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Getting Started with the PIC32CM LEO0O Using the MPLAB X IDE and
MCC

Compiling and Programming a First Application
Follow these steps to using the PIC32CM LEQO Curiosity Pro evaluation kit based on the MPLAB X IDE environment:

1. Launch MPLAB X IDE.

2. Connect the PIC32CM LEOQO Curiosity Pro evaluation kit through the DEBUG USB connector to the PC using
a micro-USB cable (Standard-A to Micro-AB). When the Curiosity Pro evaluation kit is connected to the
computer for the first time, the operating system will install the software driver.

Note: The driver file supports 32-bit and 64-bit versions of Microsoft® Windows® XP™  Windows Vista™,
Windows 7, Windows 8, Windows 10, and Windows 11.

Figure 3-1. Windows Messages

3. When the Curiosity Pro board is powered, the green power LED (PWR) will glow and the MPLAB X IDE will
auto-detect the connected Curiosity Pro Kit.
Note: The PIC32CM5164LE00100 device is programmed and debugged by the on-board embedded
debugger (EDBG), hence external programmer or debugger tool is not required.

4. From the Toolbar, select File > Open Project, or click (the project icon).
Figure 3-2. MPLAB X IDE - Open Project
File Edit MHC View Navigate Source Refa
1 New Project... Ctrl+Shift+N
P9 New File... Ctrl+N
(=3 Open Project... Ctrl+Shift+0

5. As an example, navigate to C:\H3\csp_apps_pic32cm_le_Is\apps\port\port_led_on_off _polling\firmware, and
then open the pic32cm 1e00 curiosity pro.X project file.
Note: The system may Erompt_a message to upgrade the product DFP. Upgrade if it is requested.

6. Select the Connected Hardware Tool by performing these actions:
a. To set the project as the main project: Right-click on the project name, then choose Set as Main Project.
b. To open the project properties: Right-click on the project name and select Properties.

c. Inthe Project Properties, select the connected PIC32CM LEOO Curiosity Pro board from the Connected
Hardware Tool drop-down list.

© 2022 Microchip Technology Inc. Application Note DS00004511 B-page 10
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Figure 3-3. Project Properties - Connect Hardware Tool

Categories: Configuration
o @ General Farnily:
- ----- 2 File IndusionExdusion 2l Families
=~ @ Conf: [pic32cm_le00_curiosity _pro]
> 2 EDBG Connected Hardware Tool:
L i
Loading Mo Tool w
& @ Libraries
- @ Building
B @ %32 (Global Options) PIC32CMLEDO Curiosity Pro-SN: MCHP3365020000000073

e 1 w3 ome

d. Ensure to have the most recent CMSIS, DFP and XC32 version available and selected in the Project
Properties window.
e. Click Apply, and then click OK.
7.  Compiling and running the application:
a. To build and program the project, select Production > Make and Program Device Main Project, or click

.3

(the build icon).
[X]
=
3
b. To debug the project, select Debug > Debug Main Project, or click (the debug icon).
c. The application is now programmed. Press the switch button SWO to light ON the on-board LEDO.

3.2 Proceeding with MCC
Follow these steps to proceed with MCC and update the MCC core:

MEE

1.  Go to Tools > Embedded > MPLAB Code Configurator, or click . (the MCC icon) to open the MCC
plugin. A message may prompt to update the project to latest MCC version, click OK.

2. Click on Select MPLAB Harmony in the MCC Content Manager wizard.

3. Scroll down to MPLAB Harmony Core and select the bsp and core optional packages as shown in the
following figure:
Figure 3-4. BSP and Core Optional Packages Selection

KRWrdow x| Packs x| StatFage x| ContentManager =
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Scroll up and then select Finish to open the MCC graphical user interface (GUI). The project will take some
time to open in MCC as the tool will download any missing or selected packages.

The following messages might be displayed:

a. To warn that the project packages differ from the local packages. Click Continue.

b. To update DFP version. Accept by entering Yes.

c. To update the project's Common Microcontroller Software Interface Standard (CMSIS). Confirm by
selecting Yes.

The MCC GUI will be displayed:

Figure 3-5. MCC GUI Overview for PIC32CM LEO0O Curiosity Pro Board

Fregects | Flan | Servews | Resoart. | o] | $ranc x| Freciocn * | [=][E] [ confiquration tptons =
Project Re... | Sen. | tmee || B ||| G2 3C |03 M D LB o | i |Pugee: vew: [Roat i H
¥ Lbrdes =
* Hsmany - Ferfamnance Level Selsd: Perferaarce vl 2
i RVHCTRL
) Earipharal Lbrary | Foree device to i n ALD u]
* Perigherats | mEMoay Pt RAM i low power during stardby mods o
. ENEYS e PUETRLSTRAM i low power during standty mode [
> HUMCTRL Powar Damain Configuratian FOSH porver dann sedichingis handed by harteare.
. Dyviamic Pawar Gatng Enabic O
Bow Velbaos Reguator coaratian in Stancky made | Adreicreds -
AN Bawa =
Davice Resources |Gontent Moreger
| —

7. Click the Content Manager tab.

In the Content Manager window, scroll down to MCC Harmony Core and choose the latest available version
(1.0.9 is shown as an example).

Figure 3-6. MCC MPLAB Harmony v3 Code Update

Proje... Files Servi... | Class... | Res... x] [=] || StartPage xl Packs x[ Project Graph = I Content Manager xI
Project Res... | Gen.. || Im.. || E. 0 2
~ Cl Type to Search Globally...
¥ Libraries
¥ Harmony (D csp_apps_sam_g55 320 v Latest
P Packs (@ harmony-services 100 Latest
¥ Peripherals Harmony Aerospace solutions E's
B EVSYS Harmaony Graphics (Aria) solutions E's
r _BLGCTE] Harmony CryptoAuthLib solutions Eos
Device Resources Content Manager armm Mbed 05 Ees
¥ Libraries MCC Harmony Core o
Oy @
b {_ Harmony b 109 Latest

com.microchip.mcc.harmony.Harmony3Library

~ 109 - flocal]

Hamony Capacitive Touch solutions
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The MCC Core is now up to date. Users can benefit from the latest MCC features for an existing application or for

creating a new project. To create a new MCC project, go to Files > New Project > 32-bit MCC Harmony Project as
shown in the following figure:

Figure 3-7. MCC Project Creation under MPLAB X IDE

E:i Mew Project

X
Steps Choose Project
1. Choose Project Q, Filter:
2 ..
Categories: Projects:
~I2) Microchip Embedded 3’ 32-bit MPLAB Harmony 3 Project
I3 Other Embedded 2l Standalone Project

) Samples Tl 32-bit MCC Harmony Project

...... ) Generic el Existing MPLAB IDE w8 Project

m Prebuilt (Hex, Loadable Image) Project
[5 User Makefile Project

m Library Project

m Import START MPLAE Project

[&dl Import Atmel Studio Project

Description:

MPLAB® MCC Harmony Project Wizard

< Back Finish Cancel Help
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Getting Started with the PIC32CM LS00/LS60 TrustZone Projects
Using MPLAB X IDE and MCC

PIC32CM LS00/LS60 Security Concept Overview

Using the PIC32CM LS00/LS60 requires familiarity with different security features and concepts that involve
TrustZone® for ARMv8-M devices.

The TrustZone technology is a System-on-Chip (SoC) and MCU system-wide approach to security that enables
Secure and Non-Secure code to run on an MCU. It enables creating multiple software security domains that restrict
access to selected memory, peripherals, and 1/O to trusted software without compromising the system performances.
The user can consider the following deployment approaches:

» Single-developer approach (Customer A)

» Dual-developer approach (Customer A + Customer B)

The single-developer approach involves a unique developer (Customer A), which oversees the following:

» Developing, deploying, and protecting the Secure code
» Developing and deploying the Non-Secure code

In the dual-developer approach, the first developer (Customer A), oversees developing the secure application and
its associated non-secure callable library. The secure application must be loaded in the PIC32CM LS00/LS60 NVM
secure memory and other secure areas.

A different developer (Customer B) will then start the Non-Secure application development on a preprogrammed
PIC32CM LS00/LS60 with limited access to secure resources (through calls to Non-Secure API only).

Figure 4-1. Single-Developer Approach

Developer

A End-User

Microchip
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Figure 4-2. Dual-Developer Approach

Developer - Developer

A mmp B
This document describes how to debug an MPLAB project composed of two sub-projects (Secure and Non-Secure).

Note: Refer to the PIC32CM LS00/LS60 Security Reference Guide (DS00003992), which describes the security
features available in the Microchip PIC32CM LS00/LS60 microcontroller, which fulfill the security requirements of
most embedded systems.

Microchip End-User

Compiling and Programing a First Application
Follow these steps to use the PIC32CM LS00/LS60 Curiosity Pro evaluation kit based on MPLAB X Environment in
order to run and debug a TrustZone based project.

Note: The following steps are demonstrated based on the PIC32CM LS00 Curiosity Pro board, but are fully
reproducible with a PIC32CM LS60 Curiosity Pro board.

1. Launch MPLAB X IDE.

2. Connect the evaluation kit through the DEBUG USB connector to the PC using a micro-USB cable (Standard-
A to Micro-AB). When the Curiosity Pro evaluation kit is connected to the computer for the first time, the
operating system will install the software drive.

Note: The software driver file supports both 32-bit and 64-bit versions of Microsoft Windows XP, Windows
Vista, Windows 7, Windows 8, Windows 10, and Windows 11.

Figure 4-3. Windows Messages

When the Curiosity Pro board is powered, the green power LED (PWR) will glow and the MPLAB X IDE will
auto-detect the connected Curiosity Pro MCU.

Note: The PIC32CM5164LS00100 and PIC32CM5164LS60100 devices are programmed and debugged by
the on-board embedded debugger (EDBG), therefore no external programmer or debugger tool is required.
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3. From the Toolbar, select File > Open Project, or click

(the project icon).
Figure 4-4. MPLAB X IDE - Open Project

.File Edit MHC View Navigate Source Refa
1 New Project... Ctrl+Shift+N

9 New File... Ctrl+N

(=3 Open Project... Ctrl+Shift+0

For example, navigate to C:\H3\csp_apps_pic32cm_le_Is\apps\trustZoneltc and open the secure tc 1s00
projects group, which contains the secure tc 1s00 NonSecure and secure tc 1s00_ Secure projects.
5. Open Secure and Non-Secure projects by double-clicking on each of the project.

Note: A prompt message may appear to upgrade the DFP. Upgrade it if is requested.
6. Select Connected Hardware Tool:

a. To set the Non-Secure project as the main project: Right-Click on the Non-Secure project name and
select Set as Main Project

Important: When the Non-Secure project is set as the main project in a TrustZone project
group, the Secure project is built before the Non-Secure project. This is possible using the
project's Loadables feature which will load all projects defined in this section before the main
project as shown in the figure below. If the Secure project is set as the main project, then only
this project and its related memory regions will be built and programmed.

Figure 4-5. Secure Project Under Non-Secure Loadable Project Section

—@ port_le_to_ls_pic32cm_ls00_cpro_NonSecure
#-E] Device actions

*l Embedded project in Chport_le |stNonSecure'firmm
+ﬁ‘ Important Files

+ﬁ Linker Files

+ﬁ Source Files

Libraries

Loadables

------ (54 port_le_to_ls_pic32cm_ls00_cpro_Secure

To open the non-secure project properties: Right-Click on the Non-Secure project name and select
Properties.

c. Select the connected PIC32CM LS00 Curiosity Pro board from the Connected Hardware Tool drop-down
menu.
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Figure 4-6. Project Properties - Connected Hardware Tool

Categories: Configuration
- @ General Family:
i~ @  File Indusion/Exdusion All Families
Conf: [pic32cm_Is00_cpro]
> EDBG Connected Hardware Tool:
2 Loading
@ Libraries
@ Building
@ ¥C32 (Global Options)

PIC32CMLS00 Curiosity Pro-5N: MCHP3356030000000005

d. Ensure to have the latest CMSIS, DFP and XC32 versions available and selected in the Project
Properties window.

e. Click Apply, and then click OK.
7. To set breakpoints to debug the complete secure tc solution, follow these steps:

a. Add a breakpoint on the nsc_TCO DutyCycle Set (duty cycle) line in the Non-Secure project
main.c file. Click on the number to the left of the line to set the breakpoint.

Figure 4-7. Setting Breakpoint in Non-Secure main.c File

E‘l main.c

Source  History ﬁl. 'lﬂ%—"‘@%

492
a3
94
a5
1
a7
a3
a9
100
=]
10z

PR e o 0| & =0

nsc SYSTICE TimerStart ()
nsc_TCO_CompareStart ();

while { trues )

{
for (duty_cycle = OxFF ; duty_cycle >= 0xl0 ; duty_cycle--)
i

nsc TCO DutyCycle Set (duty cycle):
nsc_ SYSTICK DelayMs ( delay ms );

Note: In this case, the breakpoint is placed at the line nsc_TCO_DutyCycle Set that calls the
Non-Secure callable function named TCO Compare8bitMatchOSet. This function is declared in the
pic32cm 1s00 cpro Secure_ sg veneer.lib file, which is generated once the Secure project is

built.

The call to the Secure function TCO Compare8bitMatchOSet is done in the veneer (Secure gateway).

b. Add a breakpoint on the TC0 Compare8bitMatchOSet function call in the Secure project
nonsecure_entry. c file, which is located at secure_tc_Is00_NonSecure > Source Files > trustZone
in MPLAB X IDE.

Figure 4-8. Setting Breakpoint in Secure nonsecure_entry.c File

E‘] nonsecure_entry.c =

Source

<l
52
=3
54
55

57

History | &~

extern vold secure tel matchO interrupt callback register (L id pFunction);

id pFunction);

extern vold secure tel_overflow interrupt callback register (T

wvoid _ attribute ((cmse_nonsecure _entry)) nsc TCO DutyCycle Set ( uinti_t duty cycle )

{
(] T TCU_CompaIeBbitHatchDSet (duty_cycl.e);

c. Add a breakpoint on the bool status = false line in the Secure project plib_tc0. c file located at
secure_tc_Is00_Secure > Source Files > config > pic32cm_Is00_cpro > peripheral > tc in MPLAB X IDE

project tree.
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Figure 4-9. Setting Breakpoint in Secure plib_tc0.c File

13 plib_tcd.c x
source | History MR B -0 QAT F B F LT | @00 0|8 5T
180 bool TCO Compare8bitMatchOSet( uintf © compareValue )
181| [ ¢
bool status = false;
183 if ((TCO_REGS->COUNTE.TC_STATUS & TC_STATUS CCBUFVO_Msk) == 0U)
134 {
185
lae TC CCBUF[Q] = compareValue;
187
188
129
150 return status:

191 = 1}

When debugging the secure application veneers, only hardware breakpoints must be used

to stop code execution on a Secure Gateway (SG) instruction. Using software breakpoints
implies the addition of a breakpoint (BKP) instruction before an SG instruction, which triggers
a Secure fault during the code execution. This behavior is normal, as the first instruction to be
executed when accessing the Non-Secure Callable (NSC) region must be an SG instruction.

A\ CAUTION

8. To compile and run the application, follow these steps:
a. To build and program the projects: Select Production > Make and Program Device Main Project, or click

.3

(the build icon).

| &
(@]
BLD
b. To debug the project, select Debug > Debug Main Project, or click (the debug icon).

c. The application is programmed and the debugger breaks in the Non-Secure project at
nsc TCO DutyCycle Set.

Farie}

9. Continue the debugging session by clicking the button.

10. As aresult, the debugger will stop successively on:
a. Thensc TCO DutyCycle Set (duty cycle) function call (Non-Secure project).
b. The TCO Compare8bitMatchOSet function call (Secure project).
c. Thebool status = false line (Secure project).

4.3 Proceeding with MCC
Follow these steps to proceed with MCC and update the MCC core.

mece)

1. Go to Tools > Embedded > MPLAB® Code Configurator, or click - (the MCC icon) to open the MCC
plugin.

2. A prompt message may appear to update the project to the latest MCC version, click OK.

3. Click Select MPLAB Harmony in the MCC Content Manager wizard.
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4. Scroll down to MPLAB Harmony v3 Core and select the bsp and core optional packages as shown in the
following figure.

Figure 4-10. BSP and Core Optional Packages Selection

KRWrdow x| Packs x| StatFage x| ContentManager x|

net_apps _tam_en i1

5. Scroll up and then select Finish to open the MCC graphical user interface (GUI). The project will take some
time to open in MCC as the tool will download any missing or selected packages.

6. The following messages may appear:
a. To warn if the project’s packages differ from the local packages, click Continue.
b. To update the DFP version, click Yes.

c. To update the project's Common Microcontroller Software Interface Standard (CMSIS), confirm by
selecting Yes.

7. The MCC GUI will be displayed, select Content Manager.
Figure 4-11. MCC GUI Overview for PIC32CM LS00/LS60 Curiosity Pro Board

Vraie. | Pl | Sarw... | Chsi. | Rev. x| L] | StriPme o Pade | Proeciorch ® 1 [=)E] | contguration optins =
Project Res.., | Gene | fme || B (@G0 ] I3 |2 E O E £ |5 |Aoe: z e = BN
tomes ' e
Femiey Ferfanmancs Level Select FarbrmurceLm 2 -
ks Faree device to min in FLO [m]
Perphenic Puk RAM i kaw power chrireg standay mode [m]
ik BLE TrustREM In o pawer durng standbe made O
b N, 8 Powar Daman Confpration FOSH 5 forced ACTHE:
Device Resources [Lcomtert wanager Dynamic Pawer Gaang Enabla [}
v Loane: “eltaga Ragustor operation in Standby mads At mods
» {7 Hamony R Powar Switch Canfiguration 58 bt

8. Scroll down to MCC Harmony Core, and update it to the latest version (1.0.9 is used as an example).
Figure 4-12. MCC MPLAB Harmony v3 Code Update

Proje...  Files Servi...  Class...  Res.. x] [=] Start Page x] Packs x[ Project Graph = I Content Manager xl
Project Res... | Gen.. | Im. | E. | @ | © .
N - 7 (1 Type to Search Globally...
¥ Libraries
¥ Harmony (1) csp_apps_sam_g55 320 v Latest
» Packs (@ harmony-services 100 Latest
¥ Peripherals Hamony Aerospace solutions Eer
» EVEYS Hamony Graphics (Aria) sclutions Ee
e BVBACTRI i Harmony CryptoAuthLib selutions B
Device Resources Content Manager am Mbed QS e
¥ Libraries MCC Harmony Core E-3
¥ {_} Harmony ‘.-"' ) . 109 v Latest
com.microchip.mcc.harmony.Harmony3Library
. i ~  1.09 - [local]
Hamony Capacitive Touch solutions
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The MCC Core is now up to date. It is now possible to benefit from the most recent MCC features for an application
or creating a project. To create a new MCC project, go to Files > New Project > 32-bit MCC Harmony Project as

shown in the following figure:
Figure 4-13. MCC Project Creation under MPLAB X IDE

ﬂ Mew Project

Steps Choose Project
1. Choose Project Q, Filter:
2 ..

Projects:

Cateqgories:
2 32-hit MPLAB Harmory 3 Project

bl Standalone Project

| 32-bit MCC Harmony Project
led Existing MPLAE IDE w8 Project
m Prebuilt (Hex, Loadable Image) Project
[l User Makefile Project
[5d Library Project
m Import START MPLAE Project
m Import Atmel Studio Project

Description:
MPLAB® MCC Harmony Project Wizard

< Back Finish Cancel Help
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Getting Started with the PIC32CM LS60 Using Trust Platform Design
Suite (TPDS) v2

Trust Platform Design Suite v2

The Trust Platform Design Suite (TPDS) v2 tool is Microchip’s dedicated software platform to onboard with
embedded security. In addition to offering Secure Element and security solutions, Microchip also offers a full
onboarding experience to start with embedded security (including but not limited to trainings and interactive
documentation) to leverage Microchip's secure and optimized provisioning flow.

Figure 5-1. Trust Platform Design Suite Tools
—
O

\ MICROCHIP

TRUS FL _W 15 EN SI.IITE

L]

THI.IET THI.IET .THI.IET

L] Fa

Users can download the TPDSv2 tool from the Microchip website, which is available under the Embedded Software
section: https://www.microchip.com/en-us/product/SW-TPDSV2.

Refer to the Microchip Developer Help website to install the TPDSv2 tool: https://microchipdeveloper.com/
authentication:trust-platform-v2.

© 2022 Microchip Technology Inc. Application Note DS00004511B-page 21
and its subsidiaries


https://www.microchip.com/en-us/product/SW-TPDSV2
https://microchipdeveloper.com/authentication:trust-platform-v2
https://microchipdeveloper.com/authentication:trust-platform-v2

AN4511
Getting Started with the PIC32CM LS60 Using ...

© 2022 Microchip Technology Inc. Application Note DS00004511 B-page 22
and its subsidiaries



5.2

AN4511
Getting Started with the PIC32CM LS60 Using ...

Running the PIC32CM LS60 Secure Boot Use Case from TPDS v2

This section provides the detailed description of the steps to follow for running the PIC32CM LS60 Secure Boot
use case in TPDS v2. The goal of this use case is to sign the boot memory region of the software to support the
PIC32CM LS60 Secure Boot feature in combination with the ATECC608B embedded secure element.

The following figure illustrates the steps documented in this section:

Figure 5-2. PIC32CM LS60 Secure Boot Use Case - Sequence Diagram

TPDS v2 PIC32CM LS60 Cpro
Step 1 : :
» Flash TPDS v2 serial bridge through DEBUG USB > !
~ Communicate device and secure element details through TARGET usB("
Generate Public / Private Keys on computer
—»
Step 2
Generate IOPROTKEY on computer
PRELENN Load hex file, calculate BOOTPROT region digest
and signature then flash secrets via TARGET USB(") -
»
Step 4
Save signed hex file on computer
»
Step 5
Program signed hex file through DEBUG USB =
Lad

Note:
1. The serial bridge programmed during step 1 is used to communicate between TPDS and the embedded
ATECCG608B secure element through the TARGET USB connector.

As an example, a test software (with Boot and Application memory regions defined) is provided in the TPDS v2
installation folder.

The defined boot memory region sets the device configuration and memory security attribution. This section of the
software will be signed with TPDS secrets.

Refer to the “PIC32CM LS00/LS60 Security Reference Guide” (DS00003992) for additional information on Secure
Boot using the ATECC608B CryptoAuthentication™ device.
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The boot software will initialize the system and jump in the secure application. The application region (containing
the Secure and Non-Secure regions) will light up both on-board LEDs. The green on-board LED is lit in the Secure
application while the red LED is lit in the Non-Secure application.

This hex file will be used to highlight the Secure Boot use case. This example has the following memory
configuration:

Figure 5-3. Test Software Flash Memory Mapping
- FLASH (524,288 Bytes)

M  Secure memory region

ST ) Non-Secure Callable

Bytes

BOOTPROT

memory region

1 Non-Secure memory region

AS

APPLICATION

ANS

Note:

The Secure Boot memory region length is defined by the BOOTPROT fuse, while this memory region protection and
verification method is defined by the BOOTOPT fuse. For this example, BOOTPROT = 0x2AA and BOOTOPT = 0x4.
Refer to the product data sheet for additional information

To run the PIC32CM LS60 Secure Boot use case in TPDS v2, follow these steps:

1. Open the TPDS v2 tool.
2. Select Use cases on the top menu.
3. Select the Secure Boot — PIC32CMLS60 use case: Select Security Solution > Use Cases menu.
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4. Scroll down to Available solution by provisioning flow and select Secure Boot — PIC32CMLS60 use case
under the TrustFLEX menu.

5. Connect the PIC32CM LS60 Curiosity Pro board to the computer through the Debug USB and Target USB
connectors.

6. Scroll down to the use case graph and execute step 1 ‘Generate Private/Public key pair’ by clicking the
icon.
Notes:
1. If the serial bridge is not already running out of the PIC32CM LS60 Flash memory, it is programmed
by the TPDS v2 tool using MPLAB X IDE, resulting in some delay before this step is completed. The
progress of the programming can be tracked on the console to the right of the TPDS v2 window:

Figure 5-4. Use Case Console Log

Clear Output

Connect to

board conne
Programming
Programming

E RS

FI & S B ]

2. When step X is completed, the “Executed Step-X Successfully” message will be displayed as shown
above. Ensure that this message is displayed before executing the next step.

7. Inthe Private Key Selection dialog box, select ‘Generate Private key'.
8. Click OK:
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Figure 5-5. Private Key Selection Window

® Private key selection - Trust Platform Design Suite ? X

Select Secure Boot private key option

Generate Private key - Generates new Secure Boot private key
Upload Private key - Use existing private key file. Requires private key file .pem

|Generate Private key ™

OK Cancel

The private and public keys will be generated on the Host computer (usually at the following location:
C:\Users\XXXXX\.trustplatform\pic32cmls60 secure boot):

Figure 5-6. Generated Public/Private Keys
slot_15_ecc_private_key.pem 6/21/2022 11:15 AM PEM File 1KB

:;’ slot_15_ecc_public_key.h 6/21/2022 11:15 AM H File 1KB
slot_15_ecc_public_key.pem 6/21/2022 11:15 AM PEM File 1KEB

9. Execute step 2 ‘Generate IOPROTKEY Key’ by clicking the 2 icon. The IOPROTKEY key will be generated
in the local folder.

Figure 5-7. Generated IOPROTKEY Key

H File TKB
PEM File 1KB

,'_';,’ slot_B_secret_key.h B2

slot_&_secret_key.pem B/21/2022 11:28 AM

Note: The I/O Protection Key (IOPROTKEY) allows encrypting the communication between the PIC32CM
LS60 microcontroller and the ATECC608B secure element.

10. Execute step 3 ‘Load hex file, calculate digest and signature’ by clicking the 3 icon. The local folder
containing the test hex file will open in a prompt window.

11. Select the test.hex file, and then click Open:
Figure 5-8. Upload Test Software Hex File

® Upload Hex File K

b= - AUse \.trustplatform\pic32cmlsel secure boo ! 5]

Organize * New folder JE [ 7]
i) Mame Date modified Type Size
# Quick access

1 . 4 test.h 6/21/2022 11:04 AM HEX File
Moeiop ¢ [eiesthe] i
¥ Downloads
‘| Documents & ,
File name: | “ | |(*hex) i

cance'

Note: The boot memory region to sign is defined by the BOOTPROT fuse bit. This must be generated per the
data sheet configuration for secure boot. Refer to the product data sheet for additional information on Secure
Boot using the ATECC608B secure element.
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12. Execute step 4 ‘Save new application hex’ by clicking the' 2 icon to create the signed hex file from the test
hex file used at the previous step:

Figure 5-9. Generated Signed Hex File

® signed.hex 6/21/2022 11:51 AM HEX File 10KB

13. Launch step 5 by clicking the 2 icon to Flash the signed hex file in the connected PIC32CM LS60 device.
Note: This step will take some time to complete. Check the completion status in the log.

The test application is now flashed in the connected PIC32CM LS60 device. The on-board LEDs will light ON with
a slight delay due to Secure Boot verification, refer to the chapter “Electrical Characteristics” in the product data
sheet for wake-up timings.
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5.3 Adding Secure and Non-Secure Applications

If the Boot software is already flashed, an application software can be added (Secure and Non-Secure). If the Boot
software and the Secure applications are already flashed, a Non-Secure application can be added. However, care

must be taken not to erase the existing code. The following figure illustrates the different memory regions, and the

ChipErase function to apply depending on if a Secure or a Non-Secure application is programmed:

Figure 5-10. Chip Erase Commands

Secure Flash
(BOOT Region)

Non-Secure Callable Flash
(BOOT Region)

Secure Flash
(APPLICATION Region)

Non-Secure Callable Flash
(APPLICATION Region)

Non-Secure Flash
(APPLICATION Region)

Secure Data Flash

Non-Secure Data Flash

CMD CEx: 0 1 2
The following sections explain how to configure the ChipErase function applied during the Secure and Non-Secure
application programming:
5.3.1 Adding a Secure Application
Follow these steps to add a Secure application:

1. In MPLAB X IDE, open the Secure application to program.

2. Under the project tree, select the project, and then right-click and choose Properties.
3. Inthe Project Properties window, select EDBG.
4,

In the Options for EDBG properties page, choose and select these options:
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— For Option Categories, select Program Options.
— For Chip erase type, select All memories excluding BOOT region (ChipErase_S).
5. Click Apply, and then click OK.
Figure 5-11. Secure Application - Chip Erase Type Selection

Categories: - e
wo @ General SIS
- ----- @ File Indusion/Exdusion Option categories: |Program Options M =
B Conf: [pic32cm_Is00_cpro
e @ @ Compute boot signature
@ Loading Wutocarrect urow/bocor checksums
- @ Libraries
o Buidi Erase key with validation OxFFFFFFFF, OxFRFFFFFF, OxFFFFFFFF  OxFFFFFFFF
uilding
S @ XC32 (Global Options) iChip erase type All Memories exduding BOCT region (ChipErase_S) ~
i O xc32-aS Set PC and SP to VTOR ]
@ xc32-goc
e WTOR table or numerical address exception_table
@ xc32-g++
o we3zdd Board file path ${ProjectDir}/board. xboard
b @ xe32ar Erase All Before Program
e @ Analysis

QOption Description

If vou select an option its description will appear here.

Manage Configurations. ..

Manage Metwork Tools...

Cancel Apply Unlock Help

=

6. To build and program the project: Production > Make and Program Device Main Project or click (the
toolbar icon) .

The Secure application is now flashed on the product next to the preexisting Boot Secure application.

5.3.2 Adding a Non-Secure Application
Follow these to add a Non-Secure application:

1.  In MPLAB X IDE, open the Non-Secure application to program.
2. Under the project tree, select the project, and then right-click and choose Properties.
3. In the Project Properties window, select EDBG.
4. In the Options for EDBG properties page, choose and select these options:

— For Option Categories, select Program Options.

— For Chip erase type, select All Non-Secure Memory Regions (ChipErase_NS).
5. Click Apply, and then click OK.
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Figure 5-12. Non-Secure Application - Chip Erase Type Selection

Categories:

General Options for EDBG
File Incusion,Exdusion Option categories: IProgram Options ~ I —
Conf: [pic32cm_Is00_cpro
o @ Compute boot signature
@ Loading Wutocarrect urow bocor checksums
@ Libraries
L Erase key with validation OxFFFFFFFF, OxFFFFFFFF, DxFRFFFFFF , OxFRFFFFFF
- @ Building
S O ¥C32 (Global Options) IChip erase type All Non Secure Memory Regions (ChipErase_NS) ~
i @ xc32-as Set PC and 5P to VTOR ]
@ xc32-goc
e WTOR table or numerical address exception_table
@ xc32-g++
o we3zdd Board file path ${ProjectDir}/board. xboard
o xc32ar Erase All Before Program
Analysis

Option Description

If vou select an option its description will appear here.

Manage Configurations. ..

Manage Metwork Tools...

Cancel Unlock Help

6. To build and program the project: Production > Make and Program Device Main Project or click (the
toolbar icon) .

The Non-Secure application is now flashed on the product next to the preexisting Boot Secure and Non-Secure
applications by offering a complete TrustZone experience.
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Troubleshooting

Troubleshooting
Compilation Error Under MPLAB X IDE Due to too Long of a Project Path
If an MPLAB X IDE project path is too long, the project will not compile and an error message will be displayed.

To resolve this issue, users need to move the project for compiling or programming to a smaller project path, for
example, desktop or C:\.
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For additional information regarding Microchip products and services, visit Microchip Website, or contact a local
Microchip sales representative.

The following documents are provided for reference purposes.

+ MPLAB X IDE:
www.microchip.com/mplab/mplab-x-ide

*  MPLAB Harmony v3:
github.com/Microchip-MPLAB-Harmony

* MPLAB Discover:
mplab-discover.microchip.com/

+ PIC32CM LEOO/LS00/LS60 Family Data Sheet (DS60001615)

* PIC32CM LEOO/LS00/LS60 Family Silicon Errata and Data Sheet Clarifications (DS80000906)
+ PIC32CM LEOO/LS00/LS60 Curiosity Pro User Guide (DS70005443)

* PIC32CM LEOO/LS00/LS60 Curiosity Pro Board Change Notification (DS70005491)
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The Microchip Website

Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

* Product Support — Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

* General Technical Support — Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

» Business of Microchip — Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

» Distributor or Representative

* Local Sales Office

» Embedded Solutions Engineer (ESE)
» Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip products:

» Microchip products meet the specifications contained in their particular Microchip Data Sheet.

* Microchip believes that its family of products is secure when used in the intended manner, within operating
specifications, and under normal conditions.

» Microchip values and aggressively protects its intellectual property rights. Attempts to breach the code
protection features of Microchip product is strictly prohibited and may violate the Digital Millennium Copyright
Act.

* Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code
protection does not mean that we are guaranteeing the product is “unbreakable”. Code protection is constantly
evolving. Microchip is committed to continuously improving the code protection features of our products.

Legal Notice

This publication and the information herein may be used only with Microchip products, including to design, test,

and integrate Microchip products with your application. Use of this information in any other manner violates these
terms. Information regarding device applications is provided only for your convenience and may be superseded

by updates. It is your responsibility to ensure that your application meets with your specifications. Contact your
local Microchip sales office for additional support or, obtain additional support at www.microchip.com/en-us/support/
design-help/client-support-services.
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