MICROCHIP AN4666

Getting Started with 32-bit Microcontroller Curiosity Pro/
Ultra Evaluation Kits

Abstract

This document aims at getting started with any SAM or PIC32 microcontroller and its associated Curiosity Pro/Ultra
evaluation kit.

The evaluation kits are supported by the MPLAB® X Integrated Development Environment and provide an easy
access to the features of the microcontrollers.

© 2022 Microchip Technology Inc. Application Note DS00004666A-page 1
and its subsidiaries



AN4666

Table of Contents

Y 0] (=T SO PSRRI 1
1. Obtaining a Curiosity Pro/Ultra Evaluation Kit.................oociiiiiiiiiiee et 3
2. TOOIS @NA SOMWAIE. ......eeiiiiiii ettt ettt e e e ettt e e e e e s nteeea e e e sbeeeaaeaannnbeeaeeaannsaeeaaeaannns 4
2.1. MPLAB X Integrated Development ENVIronmMenNt...............ooiiiiiiiiiiiiee e 4
2.2, MPLAB Code CONfIQUIALON.......cooi ittt e e et e e e e e e e e e e aneeeeaaeeannees 5
2.3, MPLAB HAIMMONY V3.t ettt b e ettt e sb e e nbb e e e et e e nneeeennneeean 7
D |V | I = B 1T 1Y PSSR 9
3. Getting Started with any PIC32 or SAM Microcontroller Using the MPLAB X IDE and MCC............... 10
3.1.  Compiling and Programming a First Application.............cccooiiiiiiiiii e 10
3.2, Proceeding With MCC...... .o et e e e et e e e e e e e e e e e aneaeeaeeean 11
S (o101 o] (=] g o To) {1 s o TSSO PPPS 14
LT = (=14 Y [o SRR 15
11V [Tt go Tt o] o TN 1) 0] a3 = 1 [o o ST 16
The MICroChip WEDSITE. ..ot 16
Product Change Notification SErVICE. .........ccooiuiiiii i 16
CUSTOMET SUPPOIL. ...ttt et e e e e ettt e e e e e e aaa e e e e eesabaeeeeesasaseeeeeaassssasaeeasnreneeeesanses 16
Microchip Devices Code Protection FEAtUre..........coeviiiiiiiiii e 16
[I=To |l N o] (T PSP TPRPPPPRO 16
L= 1o (=T 4 =T U 17
Quality Management SYSTEM......ccuiiiiiiie ittt 18
Worldwide Sales and SEIVICE...........ooi ittt e et e e e e sttt e e e e e et eeeaeaasnneeeeaeaannnees 19
© 2022 Microchip Technology Inc. Application Note DS00004666A-page 2

and its subsidiaries



AN4666

Obtaining a Curiosity Pro/Ultra Evaluation ...

Obtaining a Curiosity Pro/Ultra Evaluation Kit

The Curiosity Pro/Ultra evaluation kits are hardware platforms for evaluating the Microchip SAM/PIC32
microcontrollers (MCUs). Each evaluation kit is supported by the MPLAB X IDE and MPLAB Harmony v3, featuring
application examples.

The Curiosity Pro/Ultra evaluation kits include an on-board embedded debugger to program or debug the target
microcontroller. This enables an easy start to a project, and provides application examples that can be used in the
design of a custom application.

The Curiosity Pro/Ultra evaluation kits provide easy access to the features of the microcontroller, and are integrated
with Arduino Uno, mikroBUS™, and extension headers to interface with Xplained Pro extension boards for a rapid
prototyping and expanded functionality.

The Curiosity Pro/Ultra evaluation kits can be purchased at Microchip Direct.

Figure 1-1. Curiosity Pro/Ultra Evaluation Kit (PIC32CM JH01 Example)
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2. Tools and Software

21 MPLAB X Integrated Development Environment

The MPLAB X Integrated Development Environment (IDE) is an expandable, highly configurable software program
that incorporates powerful tools to discover, configure, develop, debug, and qualify embedded designs for most of
the Microchip’s microcontrollers and digital signals controllers. MPLAB X IDE works seamlessly with the MPLAB
development ecosystem of software and tools.

Figure 2-1. MPLAB X IDE Icon

X IDE

.

Users can download MPLAB X IDE from the Microchip’s website: www.microchip.com/mplab/mplab-x-ide.

Installing the Device Family Packs (DFP)
Follow these steps to install the DFP:

1. Open MPLAB X IDE.
2. From the Toolbar, select Tools > Packs.
3. Enter the microcontroller's name in the DFP search box, and then install the latest DFP available.
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2.2 MPLAB Code Configurator

The MPLAB Code Configurator (MCC) is a free graphical programming environment that generates seamless, easy-
to-understand ‘C’ code to insert into projects. Using an intuitive interface, MCC enables and configures a rich set of
peripherals and functions. MCC supports 8-bit, 16-bit, 32-bit PIC®, and SAM® microcontrollers. MCC is incorporated
into MPLAB X IDE as a plugin.

Figure 2-2. MPLAB Code Configurator Icon

MPLAB

C ODE
CONFIGURATOR

Installing MCC from MPLAB X IDE

Follow these steps to install MCC from MPLAB X IDE:

1. From the Toolbar, select Tools > Plugins.
Figure 2-3. MPLAB X IDE Plugins Tool

Tools Window Help

Analysis >
Embedded >
Licenses >
Packs

Apply Diff Patch...

Diff

Add to Favorites

Templates
DTDs and XML Schemas

Plugins

Plugins Download

Options

2. In the Plugins window, click the Available Plugins tab and type MCC in the search box. The MCC plugin
details will be displayed (if not yet installed) as shown in the following figure.

3. Select the check box next to the MCC plugin, and then click Install.
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Figure 2-4. MPLAB Code Configurator Installation from MPLAB X IDE Plugins

B3 Plugins X

Updates | Available Plugins (1/38) | Downloaded Installed (184) Settings

— e Cra—

Install Name Category Source |l

MPLAB® Code Configurator MPLAB IDE nr

MPLAB® Code Configurator
iy Community Contributed Plugin ~

Version: 5.0.3

Author: Microchip Technology Inc

Date: 10/11/21

Source: Microchip Plugins

I page: http://www microchip.com fmec

1 plugin selected, 1678

Close Help

4. In the Plugin Installer window, follow the instructions. Select Restart Now, and click Finish when installation is
completed.
5.  MPLAB X IDE will restart with the MCC plugin installed.
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MPLAB Harmony v3

MPLAB Harmony v3 is a fully integrated embedded software development framework that provides flexible and
interoperable software modules to simplify the development of value-added features, and reduce the customer’s time
to market (TTM).

Figure 2-5. MPLAB Harmony v3 Icon

MPLAB

HARMONY
=

Go to the Microchip GitHub page, https://github.com/Microchip-MPLAB-Harmony, to download the matching
application packages:

* csp_apps_xxxx: Contains the driver, FS, system service, and RTOS application examples.
» core_apps_xxxx: Contains the Peripheral Library (PLIB) application examples.

Note: Users can download specific examples from the Microchip website: https://mplab-discover.microchip.com/.

Create a folder and name it as C: \H3, which is used as the MPLAB Harmony v3 framework folder. Unzip application
packages files in this folder as shown in the following figure:

Figure 2-6. Application Packages Unzipped in Harmony v3 Framework

| Iﬂ = | H3
Home Share View
« S > This PC > Windows (C) > H3

~ -~
Mame

core_apps_pic32cm_jh00_jhO1
csp_apps_pic32cm_jh00_jho1

Note: The MCC’s Content Manager can then be used to update the MPLAB Harmony v3 framework folder or
download new packages.
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Follow these steps to define the MPLAB Harmony v3 framework folder in MPLAB X IDE:
1. From the Toolbar, select Options > Plugins.
2. For MPLAB Harmony Configurator v3, choose MPLAB Code Configurator 5.x.
3.  For MPLAB Harmony Content Path, choose newly created H3 folder as shown below.

Figure 2-7. MCC Harmony Content Path Update

ﬂ Opticns X
Gy P g = E Q, |Filter (Ctrl+F)
oa B4 QA % IE O &

General Editor Fonts & Colors Keymap Embedded Team Appearance jPluginsfiMiscellaneous

MPLAB® Harmony Configurator 3' MPLAB® Code Configurator 5-XI

File Handling Remove unused files from the project
Delete unused files from the disk

Generated Line Endings | DOS (CRLF) -~

Editor Behavior Always ask before removing a module

[] Always ask before removing a pin

Autosave MCC configuration file

Libraries R55 Feed Enable R5S Feed for new library versions (needs IDE restart)
Enter new R5S Feed URL |https://www.microchip.com/mec_libraries_xml

Restore default RSS Feed

I Harmony Content Path  |Ci\H3 I B
[] Always ask for Harmony Content Path when opening project

Install Core Remove Core Open Core Folder
Install Library Remove Library QOpen Library Folder Reset Plugin Files
Export... Import... I oK II Apply I Cancel Help

Note: This step is optional for running an application only, but it must be verified to run the MCC plugin.

Users can define another path and name for the MPLAB Harmony v3 Framework folder, but must ensure to
define them as small as possible for tool restrictions.
Note: The C:\H3 folder will be referenced in this document, from this point forward.

4. Click Apply, and then click OK.
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MPLAB Discover

MPLAB Discover is a catalog of fully configured and complete source codes, projects, examples and software
applications for PIC® and AVR® microcontrollers to help jump-start next customer project. It features intuitive and
powerful search capabilities to search for content quickly and easily.

Figure 2-8. MPLAB Discover Icon

DISCOVER
=

For additional information about MPLAB Discover, go to Microchip website: mplab-discover.microchip.com/.
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Getting Started with any PIC32 or SAM Microcontroller Using the
MPLAB X IDE and MCC

Compiling and Programming a First Application
Follow these steps to use the Curiosity Pro/Ultra evaluation kit in the MPLAB X IDE environment:

1. Launch MPLAB X IDE.

2. Connect the Curiosity Pro/Ultra evaluation kit through the DEBUG USB connector to the PC using a micro-
USB cable (Standard-A to Micro-AB). When the Curiosity Pro/Ultra evaluation kit is connected to the computer
for the first time, the operating system will install the software driver.

Note: The driver file supports 32-bit and 64-bit versions of Microsoft® Windows® XP™, Windows Vista™,
Windows 7, Windows 8, Windows 10, and Windows 11.

Figure 3-1. Windows Messages Example

3. When the Curiosity Pro/Ultra evaluation kit is powered, the green power LED (PWR) will glow and the MPLAB
X IDE will auto-detect the connected Curiosity Pro/Ultra evaluation kit.
Note: The microcontroller is programmed and debugged by the on-board embedded debugger, therefore an
external programmer or debugger tool is not required.

4. From the Toolbar, select File > Open Project, or click (the project icon).
Figure 3-2. MPLAB X IDE - Open Project
File Edit MHC View Navigate Source Refa
1 New Project... Ctrl+Shift+N
P9 New File... Ctrl+N
(=3 Open Project... Ctrl+Shift+0

5. As an example, navigate to C:\H3\csp_apps_pic32cm_jh00_jh01\apps\port\port_led_on_off polling\firmware,
and then open the pic32cm jh01 curiosity pro.X project file.
Note: The system will prom?)t a mgssage to upg_rade the product DFP, upgrade if it is requested.
6. Select the Connected Hardware Tool and perform these actions:
a. To set the project as the main project: Select the project, right-click and choose Set as Main Project.
b. To open the project properties: Right-click and select Properties.
c. Select the connected Curiosity Pro/Ultra evaluation kit from the Connected Hardware Tool drop-down list.

© 2022 Microchip Technology Inc. Application Note DSOOOO4666A-page 10
and its subsidiaries



AN4666
Getting Started with any PIC32 or SAM Micr...

Figure 3-3. Project Properties - Connect Hardware Tool Example

Categories: Configuration
- @ General Family:

- @ File Inclusion/Exclusion

Conf: [pic32cm_jh01_cpro]
: EDBG
Loading
Libraries PIC32CM JHO1 Curiosity Pro-SN: MCHP336203000000... ~
Building No Tool
K32 (Global Options) Simulator
----- @ xuc32-as PIC32CM JHO1 Curiosity Pro-5N: MCHP3362030000000002

All Families

Connected Hardware Tool:

d. Click Apply, then click OK.
7. Compiling and running the application:
a. To build and program the project, select Production > Make and Program Device Main Project, or click

.3

(the build icon).

| &
o]
B )
b. To debug the project, select Debug > Debug Main Project, or click (the debug icon).

c. The application is now programmed. Press the switch button SWO to light ON the lon-board LEDO.
8. Open MCC and update MCC Core.

3.2 Proceeding with MCC
Follow these steps to proceed to the MCC:

1. To open the MCC plugin, from the Tool bar, select Tools > Embedded > MPLAB Code Configurator, or click

|l |--‘-|
- (the MCC icon).

2. A message will be prompted to update the project to the latest MCC version, click OK.
Select MPLAB Harmony v3 in the MCC Content Manager wizard.

4. Scroll down to MPLAB Harmony v3 Core and select the bsp and core optional packages as shown in the
following figure:

Figure 3-4. BSP and Core Optional Packages Selection

w

x| StartPage x| ContentManager =

5. Scroll up and select Finish to open the MCC graphical user interface (GUI). The project will take some time to
open in MCC as the tool will download any missing or selected packages.

6. The following messages might be displayed:
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a. To warn that project packages may differ from the local packages. Click Continue.
To update the DFP version. Accept by entering Yes.
To update project’'s Common Microcontroller Software Interface Standard (CMSIS). Confirm by selecting

Yes.

7. The MCC GUI will be displayed as shown below:
Figure 3-5. MCC GUI Overview

Peojerts | thi | Chmses | Servess | Aesows. ot G Gk iindoe s St Pege s | Pods s Fropa Gph © B[ Contapurtion Optioms = 3
Project Resour..,  Gener.  wpo. | © 8 B]X CRHORE T || Viem: (Aot = &
T < L
i MCTRL Raad Mok e IS FEALTY
™ Hamany Wk statan g
» s Frdhuction Wode Duning Sieen | WHRELR N ACTESE
¥ Perphersis fo i
The Doin Fash eathe i timbied, e main &
» s 1
* BNACTRL
81T svmcTaL
* System
Systors
Device Resources ] Conzent Manager
* Libraries
* 7 Hareany

8. Click the Content Manager tab.

9. In the Content Manager window, scroll down to MCC Harmony Core and choose the latest available version
(1.0.9 is shown as an example).

Figure 3-6. MCC MPLAB Harmony v3 Code Update

Proje... r Files T Servi... r Class... I Res... x] [=] || StartPage xl Packs x[ Project Graph = I Content Manager xI
ProjectRes...| Gen. | Im. | E. @ | O
_ K ~ Q Type to Search Globally...
¥ Libraries
¥ Harmony (1) csp_apps_sam_g55 3.20 v Latest
* Packs @D harmony-services 100 Latest
¥ Peripherals Harmony Asrospace solutions E's
» EVSYS Hamaony Graphics (Aria) solutions Eos
ke NAKACTR] ai Hammony CryptoAuthLib solutions Ees
Device Resources I Content Manager armm Mbed 05 Ees
¥ Libraries MCC Harmony Core o
> J Harmony ©o _ 108 ~ Latest
com.microchip.mcc.harmony.Harmony3Library =5
. . ~  1.0.9 - flocal]
Hamony Capacitive Touch solutions
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The MCC Core is now up to date. Users can get the recent MCC features for an application or for creating a project.

To create a MCC project follow these steps:
Go to Files > New Project. The New Project window will be displayed.

1.
2.
3.

Under Steps, select Choose Project.
In the Choose Project, under Projects, select 32-bit MCC Harmony Project as shown in the following figure:
Figure 3-7. MCC Project Creation under MPLAB X IDE
ﬂ Mew Project
Steps Choose Project
1. Choose Project Q. Filter:
2 ..
Categories: Projects:
o IC3) Microchip Embedded T 32-bit MPLAB Harmony 3 Project
i-[I3) Other Embedded [d Standalone Project
u:l Samples |32-bit MCC Harmony Project
. ) Generic bl Existing MPLAE IDE w8 Project
m Prebuilt (Hex, Loadable Image) Project
[5 User Makefile Project
m Library Project
m Import START MPLAE Project
(&l Import Atmel Studio Project
Description:
MPLAB® MCC Harmony Project Wizard
< Back Finish Cancel Help
4. Click Next.
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Troubleshooting
Compilation of Error Under MPLAB X IDE Due to Too Long of a Project Path

If an MPLAB X IDE project path is too long, the project will not compile and an error will be prompted. To solve this
issue, move the project for compiling or programming to a smaller project path, for example, desktop or C:\).
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References
For additional information regarding Microchip products and services, visit the Microchip Website, or contact a local
Microchip sales representative.

The following documents are provided for reference purposes.

+ MPLAB X IDE:
www.microchip.com/mplab/mplab-x-ide

*  MPLAB Harmony v3:
github.com/Microchip-MPLAB-Harmony

* MPLAB Discover:
mplab-discover.microchip.com/
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The Microchip Website

Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

* Product Support — Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

* General Technical Support — Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

« Business of Microchip — Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

» Distributor or Representative

* Local Sales Office

» Embedded Solutions Engineer (ESE)
» Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip products:

* Microchip products meet the specifications contained in their particular Microchip Data Sheet.

» Microchip believes that its family of products is secure when used in the intended manner, within operating
specifications, and under normal conditions.

» Microchip values and aggressively protects its intellectual property rights. Attempts to breach the code
protection features of Microchip product is strictly prohibited and may violate the Digital Millennium Copyright
Act.

* Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code
protection does not mean that we are guaranteeing the product is “unbreakable”. Code protection is constantly
evolving. Microchip is committed to continuously improving the code protection features of our products.

Legal Notice

This publication and the information herein may be used only with Microchip products, including to design, test,
and integrate Microchip products with your application. Use of this information in any other manner violates these
terms. Information regarding device applications is provided only for your convenience and may be superseded
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by updates. It is your responsibility to ensure that your application meets with your specifications. Contact your
local Microchip sales office for additional support or, obtain additional support at www.microchip.com/en-us/support/
design-help/client-support-services.

THIS INFORMATION IS PROVIDED BY MICROCHIP "AS IS". MICROCHIP MAKES NO REPRESENTATIONS
OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY

OR OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR PURPOSE,
OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL, OR
CONSEQUENTIAL LOSS, DAMAGE, COST, OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP'S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR ITS USE
WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO MICROCHIP FOR
THE INFORMATION.

Use of Microchip devices in life support and/or safety applications is entirely at the buyer's risk, and the buyer agrees
to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or expenses resulting
from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual property rights
unless otherwise stated.
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logo, MPLIB, MPLINK, MultiTRAK, NetDetach, NVM Express, NVMe, Omniscient Code Generation, PICDEM,
PICDEM.net, PICkit, PICtail, PowerSmart, PureSilicon, QMatrix, REAL ICE, Ripple Blocker, RTAX, RTG4, SAM-
ICE, Serial Quad 1/0, simpleMAP, SimpliPHY, SmartBuffer, SmartHLS, SMART-I.S., storClad, SQI, SuperSwitcher,
SuperSwitcher Il, Switchtec, SynchroPHY, Total Endurance, TSHARC, USBCheck, VariSense, VectorBlox, VeriPHY,
ViewSpan, WiperLock, XpressConnect, and ZENA are trademarks of Microchip Technology Incorporated in the
U.S.A. and other countries.

SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, Symmcom, and Trusted Time are registered
trademarks of Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany Il GmbH & Co. KG, a subsidiary of Microchip
Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.
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Quality Management System

For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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