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1: Chapter 1

1: Welcome 

What’s groov?
groov is Opto 22’s web-based operator interface system that is simple, mobile, and connects easily to 
almost everything.

Simple: groov requires only a web browser to build and view interfaces. Because it puts ready-made 
gadgets at your fingertips and requires zero programming, it’s simple to build, deploy, and view 
effective and 100% scalable operator interfaces.

Mobile: groov can be viewed on almost any mobile device or computer regardless of its 
manufacturer, operating system, or screen size, including smartphones, tablets, PCs, and even smart 
high-definition televisions. groov can augment existing human-machine interfaces (HMIs) and 
SCADA systems by making important information available at any time and in any location.

Connects easily: You can connect groov to Opto 22 controllers directly, or you can connect to 
devices from other manufacturers through a tag server that supports OPC UA (Unified Architecture). 
When connected to a tag server you can monitor and control PLCs and PACs such as Allen-Bradley 
ControlLogix and CompactLogix, Siemens SIMATIC S7, Schneider Electric Modicon, GE PACSystems, 
and many more. 
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In addition you can use groov with databases, SNMP devices, weather stations, OPC-DA servers, or 
any device or system supported by your tag server. groov gets important data from process control, 
OEM machines, and manufacturing systems into operators’ hands. (For more information about OPC 
UA, go to opcfoundation.org/UA.)

groov Build
groov Build provides a collection of gadgets for developing a graphical, on-screen operator 
interface. It comes with the built-in ability to import tags from a variety of systems and equipment, 
including SNAP PAC controllers, OptoEMU energy monitoring units, and other companys’ systems, 
devices, and databases. groov Build also allows you to manage user accounts and to import tags 
from multiple devices to use in the operator interface.

http://www.opcfoundation.org/Default.aspx/01_about/UA.asp?MID=AboutOPC
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groov View
Runs a groov operator interface that resides on a groov Box or groov Server and can be accessed 
using View on a computer, smartphone, tablet, or other device with a web browser and a network 
connection to groov.

Difference Between groov Build and View
The following chart outlines the differences between groov Build and View.

groov Build groov View

What it’s for Building an operator interface:
• Connect
• Build screens
• Authorize users
• Back up projects

Viewing an operator interface:
• Monitor and control 

equipment/system

Who uses it Authorized groov Build users: 
• An Admin has full control
• An Editor cannot authorize users

Authorized groov users: 
• An Operator can log in/out & 

change password
• Kiosk users cannot log out or 

change password

Password groov Build software password
• An Admin sets the username and 

password at first login to groov. 
• An Admin user can assign 

usernames/passwords to Editors and 
other Admins.

groov View password
A username and password are 
assigned to each user by a 
groov Build Admin.

View on a tablet 
and a smartphone
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Mobile Device Apps
groov View for iOS and groov View for Android are optional native apps for your tablet or 
smartphone. You can just use your browser to run groov, but unlike a browser these apps display 
View in full-screen mode without the address bar, toolbars, and so on. Also, you can configure the 
app with your username and password in order to skip the login screen.

The iOS and Android apps are ideal for OEMs and machine builders who want to use a tablet in kiosk 
mode as an operator interface to a machine. Kiosk mode locks the device to only run groov.

Try Before You Buy
A fully functional version of the software-based groov Server for Windows is available to download 
and try so you can see your own system’s data on a smartphone, tablet, or other mobile device. If 
you need a tag server to connect to a third-party controller, Kepware Technologies’ KEPServerEX 5 
communication platform is also available for download and trial.

How to get there in 
a web browser

groov Box
For the URL, enter:
https://[hostname]/
Or: https://[IP address]/
groov Server
For the URL, enter:
https://localhost/
Or: https://[Server’s host-
name or IP address]/ 

Click Settings (gear in upper right), and 
choose Switch to groov Build

For the URL, enter:
https://[hostname]/

How to get there in 
groov Find 
(Windows PC only)

Click Search for devices. 
Find the serial number of the groov 
Box. Click groov App.

[Not normally used]

groov Build groov View

View in browser View app
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Just download and install groov Server for Windows (groov.com), and KEPServerEX 5 
(www.kepware.com). Simple instructions walk you through software setup, connecting to one or 
more systems, and building simple interfaces so you can quickly see realtime system data on a 
mobile device. Both software packages operate for two hours without a license key.

NOTE: You must log on as an administrator to install groov Server for Windows.

A Note on Browsers
Thanks to technologies such as HTML5, SVG, and CSS3, modern browsers are now more similar than 
they are different. Consequently, our browser-based groov View and groov Build work reliably on a 
large number of device/OS/browser combinations. We’ve seen groov work on HDTVs, phones of 
many shapes and sizes, and new devices, and we test them as fast as we can get our hands on them. 
We can’t test every single device/OS/browser version available. But we’re happy to recommend 
those that work well, such as Firefox, Chrome, and Internet Explorer 10. We also encourage you to let 
us know your experiences with devices you find.

System Requirements
For groov Box and groov Server for Windows

To build operator interfaces with groov you’ll need:

• Any computer with a modern web browser. This does not have to be a Windows PC.

• One or both of the following:

– An Opto 22 SNAP PAC System (SNAP PAC S-series, R-series, or SoftPAC controller with 
firmware R9.2a or newer, running a PAC Control strategy).

– Another manufacturer’s automation system with tags accessible by your tag server. You’ll 
need a tag server that supports OPC UA plus the appropriate drivers for your system 
installed on the server computer.

groov and KEPServerEX: If you don’t already have a tag server installed that supports OPC UA, the 
KEPServerEX communication platform from Kepware Technologies is recommended by Opto 22 
and tested to work with groov.

Kepware is a leader in OPC communications and has developed hundreds of device drivers to 
communicate with automation systems, industrial databases, and other software. For more 
information, go to www.kepware.com/Products/products_OPCServers.asp. See also, 
www.kepware.com/Support_Center/doc_auto_tag.asp

For groov Server for Windows

To install and run groov Server for Windows you’ll need:

• A PC on the same network as your control device, with one of the following Microsoft 
operating systems. This can be the same computer where the tag server is installed, or a 
separate computer.

http://www.kepware.com/Products/products_OPCServers.asp
http://www.kepware.com/Support_Center/doc_auto_tag.asp
http://groov.com
http://www.kepware.com
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– Windows® 7 Professional (32-bit or 64-bit)

– Windows 8 Professional (32-bit or 64-bit) 

– Windows Server 2008 R2 

– Windows Server 2012 

NOTE: .NET Framework 3.5 or greater is required for all operating systems. Use the “Add roles and 
features” option for Windows Server 2012.

• A minimum of 250 MB available disk space to install groov Server for Windows. Additional disk 
space is required to create projects. (Projects may be created on this PC or on another 
computer.)

About This Guide
This user’s guide teaches you how to use the groov applications to build and use an operator 
interface.

This guide assumes that you have already set up your groov Box or installed and set up groov Server 
for Windows, and that you are already familiar with your personal computer’s operating system and 
how to use your tablet or smart phone.

To set up a groov Box and get started with groov, see form 2063, the groov Quick Start. See 
also, form 2077, the groov Box User’s Guide.

To install and get started with groov Server for Windows, see form 2078, the groov Server for 
Windows Quick Start.

Here’s what is in this user’s guide: 

Chapter 1: Welcome introduces this user’s guide and groov.

Chapter 2: Building an Operator Interface describes how to create pages and users, and add 
gadgets to the operator interface.

Chapter 3: Viewing Your Operator Interface describes how to open and use a groov HMI on any 
device with access to the Internet.

Chapter 4: Troubleshooting and Additional Help provides troubleshooting information and 
answers questions you may have about groov.

Appendix A: Extended Character Set lists the ASCII extended character set which you can use in 
gadget text when building an operator interface. 

Appendix B: Network Cameras describes the IP cameras that work with the Video gadget. 

Other groov Resources
Resources for groov and other related products—such as PAC Project—are also available on the 
Opto 22 website, www.opto22.com.

http://www.opto22.com/
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4363
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4382
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4381
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Product Support
If you have any questions about groov, you can call, fax, or e-mail Opto 22 Product Support.

Phone: 800-TEK-OPTO (800-835-6786)
951-695-3080
(Hours are Monday through Friday, 
7 a.m. to 5 p.m. Pacific Time)

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

When calling for technical support, be prepared to provide the following information about your 
system to the Product Support engineer:

• groov type (groov Box or Server)

• groov version. In Build, select Help > About

• A description of your system equipment:

– Computer type, speed, memory, and operating system

– Controller model and firmware version

• A description of the network

• Specific error messages or other diagnostic indications

NOTE: Email messages and phone 
calls to Opto 22 Product Support 
are grouped together and 
answered in the order received.
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2: Chapter 2

2: Building an Operator 
Interface

groov Build provides a collection of gadgets that allow you to create graphical, on-screen operator 
interfaces to monitor and manage Opto 22 control applications (or strategies) running on Opto 22 
SNAP PAC controllers, OptoEMU sensors, and a wide variety of other systems and devices. An 
operator interface created in Build resides on the groov Box or on the PC where groov Server is 
installed, and it can be accessed on a computer, smartphone, tablet, or other mobile device with a 
web browser.

This chapter describes all aspects of creating an operator interface in groov Build, including how to 
create users, pages, and groups, and how to configure gadgets.

In this chapter:
Adding a Page.................................................................................. 11
Adding a Category ......................................................................... 12
Deleting a Page or Category...................................................... 13
Renaming a Page or Category .................................................. 13
Duplicating a Page......................................................................... 14
Adding an Opto 22 PAC Controller ......................................... 14
Adding a System from Another Manufacturer.................. 16
Editing a Controller’s or OPC-UA Server’s Address........... 24
Deleting a Controller or OPC-UA Server............................... 25
Adding Gadgets .............................................................................. 26
Configuring Gadgets..................................................................... 28
Optimizing Layouts........................................................................ 40
Creating a User................................................................................. 42
Changing the Project Settings.................................................. 47
Saving Your Project and Opening groov View .................. 48
Backing Up and Restoring Your Project................................ 48
Getting groov Updates ................................................................ 49
Updating Your License ................................................................. 49
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Getting Started
To install and get started with groov Server for Windows, see form 2078, the groov Server for Windows 
Quick Start.

To set up a groov Box and get started with groov, see form 2063, the groov Quick Start. For additional 
information, see form 2077, the groov Box User’s Guide.

Opening Build
The first time you open groov, make sure to follow the instructions in one of the quick start guides 
mentioned above.

For groov Server for Windows
a. Open Firefox, Chrome, or Internet Explorer 10 and do one of the following:

– If groov Server is installed on the same computer, type https://localhost in the 
address bar of your browser.

– If groov Server is installed on a different computer, type https:// and the computer’s 
hostname. For example, if the computer’s hostname is RStarr-w7, you type 
https://RStarr-w7

You can use the IP address of the host PC instead of the hostname. However, if the PC is on 
a network with DNS and DHCP, the IP address is subject to change.

NOTE: If groov does not open, see Troubleshooting in form 2027, the groov User’s Guide.

b. Click the gear icon on the top right-hand side, and then click “Switch to groov Build.”

For groov Box 
NOTE: In order to use a URL hostname, your network must have DNS. If it doesn’t, see page 61 for 
information on how to use groov Find.

Address bar

Gear icon

http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4381
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4363
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4382
http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4361
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a. Enter https:// and your groov Box’s hostname as the URL. The hostname is printed on top of the 
groov Box. 

For example, if the hostname is opto-01-ab-c2, you type
https://opto-01-ab-c2

NOTE: If you’ve assigned a static IP address to the groov Box, use the IP address instead of the 
hostname to open groov.

b. groov opens first in groov View. To switch to Build, click the gear icon on the top right-hand side, 
and then click Switch to groov Build.

Adding a Page
You must add at least one page in order to build an operator interface.
1. In groov Build, click Add Page under Pages on the left side.

Default 
hostname
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2. Type a new name for the page. 
3. If you want, select a background color, select a category for this page, or limit the access rights. 

A category is useful for grouping of pages by location, function, and so on.

4. Click OK.

Resizing a Page
If you need more room on a page, click the Increase Height button at the bottom of the workspace. 
If you switch to another page and then return, the page will shrink to fit the content or else return to 
the default page size.

Adding a Category
A category is used to organize pages in the operator interface. For example, if you have a multi-story 
building, you could make a category for each floor, and then add pages to it that apply only to that 
floor. Or categories can represent individual machines, or rooms, or any number of things.
1. In groov Build, click Add Category under Pages on the left side.
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2. Type a new name for the category. 

3. Click OK.

Deleting a Page or Category
The process is similar for deleting either a page or a category. However, you can only delete a 
category that doesn’t have any pages assigned to it. To delete a category with pages, first move or 
delete the pages. If you add a category and don’t put any pages in it, the category will automatically 
be deleted for you when you save and open View.
1. Hover over the page or category name in the Pages panel, then click the red X that appears.

2. Click OK in the dialog box that appears.

Renaming a Page or Category
1. Right-click the name and select Rename.

2. Enter a new label, and press Enter or left-click in the work area.

Click the red X.
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Duplicating a Page
1. Right-click the name and select Duplicate.

A duplicate of the page appears in the same category.

2. If you want you can drag it to a new position.

Adding an Opto 22 PAC Controller
Follow these steps to add an Opto 22 controller that the operator interface will communicate with. 
When you add a controller and the .idb.txt file associated with the strategy that runs on the 
controller, the strategy’s tags become available in groov for you to use. Repeat the steps to add 
additional Opto 22 controllers and tags.
1. Under Gadget Palette on the right side, click Configure Devices & Tags, or select 

Configure > Devices and Tags.

The Configure Controllers dialog box opens.
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2. Click Add Opto 22 Controller.

3. Enter the hostname or IP address of the controller running the strategy you want to use.
4. Click Browse to locate the .idb.txt file you want to use.

NOTE: When PAC Control compiles a strategy it automatically generates an .idb.txt file and places it in 
the same directory as the strategy. If you are setting up groov on a computer other than the one used 
to develop the PAC Control strategy, copy the .idb.txt file into a directory that is accessible to the 
computer you are using to set up groov.

5. Click Import.

Build imports the .idb.txt file. The tag database is now available in groov.
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Updating a Strategy
If a controller’s strategy has been changed, you need to update it in groov by importing its new 
.idb.txt file.
1. Select Configure > Devices and Tags.
2. Highlight the controller you want to update, and then click Update Strategy.

CAUTION: Be very sure you are updating the correct strategy. If you use the wrong one, all of the 
controller tag connections will break. This is critical because re-importing the correct strategy will not 
fix the broken gadgets. You can only fix the connections by restoring your project with a recent 
backup.

3. In the dialog box that opens, browse to the strategy you want to use, select the new .idb.txt file, 
and then click Open.

NOTE: When PAC Control compiles a strategy it automatically generates an .idb.txt file and places it in 
the same directory as the strategy. If you are setting up groov on a computer other than the one used 
to develop the PAC Control strategy, copy the .idb.txt file into a directory that is accessible to the 
computer you are using to set up groov.

4. Close the Configure Controllers dialog box.

Adding a System from Another Manufacturer
In order for groov to communicate with devices and automation systems from other manufacturers, 
groov requires a tag server that supports OPC UA. So, before you can add tags to groov from a system 
not manufactured by Opto 22, the system must first be configured to communicate with an 
OPC UA-compliant tag server.

If you don’t already have a tag server installed that supports OPC UA, the KEPServerEX 
communication platform is recommended by Opto 22 and tested to work with groov. Kepware is a 
leader in OPC communications and has developed hundreds of device drivers to communicate with 
automation systems, industrial databases, and other software. For more information, go to 
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www.kepware.com/Products/products_OPCServers.asp. See also, 
www.kepware.com/Support_Center/doc_auto_tag.asp

Follow these steps to add an OPC UA-compliant tag server to groov that will communicate with the 
operator interface.
1. In the Gadget Palette in the lower-right corner of groov Build, click the Tags tab, and then click 

Configure Devices & Tags. Or select Configure > Devices and Tags from the menu bar.

2. Click Add OPC UA Server.

3. Enter the Name of the OPC-UA server.
4. For the Server URL, using the following format, enter the IP address or hostname of the 

computer where the OPC-UA server is installed, and enter the port (for Kepware the default is 
49320). You can also enter the path of the OPC server endpoint.

5. Click Add Server.

Adding Tags from an OPC-UA Tag Server
There are two ways that you can add tags from an OPC-UA tag server to your project, either by 
importing static tags or by adding dynamic tags. Both procedures are described below

Imported (Static) Tags. The Import Tags function imports all the static tags from an OPC-UA server. 
When imported into groov, static tags are called imported tags. They keep the server’s tag hierarchy 
and are displayed in a tree format. You will see the names of the tags, not the addresses.

Click Add 
OPC UA Server

MyComputer.MyCompany.com:49320/path

Computer hostname Port

http://www.kepware.com/Products/products_OPCServers.asp
http://www.kepware.com/Support_Center/doc_auto_tag.asp
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If a large number of tags are required for your project it can is to import the tags into groov rather 
than adding each individual tag in groov Build. This allows you to browse the tag hierarchy to find 
the tag you need.

Dynamic Tags. Dynamic Tags are tags that you enter manually one at a time in groov. Dynamic tags 
are not configured on the tag server, only on groov, so that once a device is configured on the server, 
the tags do not have to be imported into the server in order to be accessed by groov. One advantage 
is there is less maintenance required; if changes are made to a tag on the device, you do not have to 
make those same changes on the server, only on groov. Another advantage is that dynamic tags 
allow you to add as many or as few tags to groov as you want. This can make it easier to find specific 
tags if you only want to use a few.

Importing Static Tags

Unless your database is very large, the easy way to use groov is to import all of a controller’s tags into 
groov. (If your database is very large and you only want to use a few of them, see page 20.)
1. In the Gadget Palette in the lower-right corner of groov Build, click the Tags tab, and then click 

Configure Devices. Or select Configure > Devices and Tags from the menu bar.

2. In the Configure Devices and Tags dialog box, select the OPC-UA server and click Import Tags.

In a moment you should see the Imported Tags dialog box which lists the names of the 
imported tags.

Click Import 
Tags

Select the 
server
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3. Click Close.
4. Close the Configure Devices and Tags dialog box.

The imported tags are now available on the Tags tab of the Gadget Palette.

5. Now you’re ready to add gadgets to a page using the tags you just imported. For instructions, 
see “Adding Gadgets” on page 26.

6. After you’ve added some gadgets and associated tags to them, select File > Save All Changes 
and Switch to groov View.

It might take a few moments for the OPC-UA connection to be established and live values to 
appear.

Imported tags
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Adding Dynamic Tags

Follow these steps to add tags manually:
1. In the Configure Devices dialog, select the OPC-UA server and click Configure Dynamic Tags.

2. In the Configure Tags dialog box, click Add.
3. In the Add Dynamic Tag dialog box, enter a Name and select the Data Type.

You must also make sure the Data Type selected in groov matches the type retrieved from the 
device.

4. If this tag is an array of objects with the same data type, select Array and enter the array size.
5. Choose the Access Read or Write attributes as needed.

Leave this dialog box open while you identify the NodeId Value in the next step.

6. To find the NodeId Value for your device, open your OPC-UA server configurator and find the 
configured device associated with this tag. 

You’ll find part of the NodeId information here. The remainder comes from the device itself. The 
addressing syntax is different for each type of device, so you’ll need to check the OPC-UA 
server’s documentation for this tag’s device type.

Click Configure 
Dynamic Tags

Select the 
server
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As an example, here’s how you find the NodeId for an Rockwell Automation Logix tag on a 
KEPServerEX 5 server:

a. Open the KEPServerEX 5 Runtime configurator.
b. Locate the device and tag from which the dynamic tag in groov will obtain data.

Use this format for the NodeId Value:
[Channel name].[Device name].[Tag group name].[protocol specific address]
So now you can extract the information you need from the server’s configurator and the 
device itself:
[Channel name]=DTOL
[Device name]=Cmplx5370
[protocol specific address]=Program:MainProgram.i32Counter@Long

NOTE: The protocol specific address is obtained from the device. If you have a Kepware server, the 
help file provides the protocol specific addressing information. To access help for a specific tag, 
click on the device name in the Kepware configurator, choose Properties, and click the Help 
button.

In this example, the “@Long” portion specifies the data type as an unsigned 32-bit integer. This 
forces the server to report data to this type. If the default data type on the Kepware server is 
different than the tag’s data type, the link will fail in groov unless you specify the data type in the 
NodeId Value. For more information on your specific data type, see the server’s documentation.

Putting it all together, here’s the NodeId Value for this dynamic tag:
DTOL.Cmplx5370.Program:MainProgram.i32Counter@Long

7. In the groov Add Dynamic Tag dialog box you left open in groov Build, enter the NodeId Value.
8. In most cases, the Namespace Index should stay at 2. However, for some servers (such as 

Ignition by Inductive Automation) you should change the Namespace Index to 1.

A tag’s Namespace Index is an integer (0 or higher) that tells groov how to find the tag on the 
server.

9. Click Add Dynamic Tag.
10. Close the open dialog boxes.

Channel name

Device name
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The new dynamic tag appears in the Gadget Palette.

11. Now you’re ready to add gadgets to a page using the new tags you just created. For 
instructions, see “Adding Gadgets” on page 26.

12. After you’ve added some gadgets and associated tags to them, select File > Save All Changes 
and Switch to groov View.

It might take a few moments for the OPC-UA connection to be established and live values to 
appear.

Configuring the Windows Firewall for an OPC-UA Server
if you are using groov Server installed on a different computer than the OPC-UA server or a groov 
Box, inbound traffic to the OPC-UA server needs to be able get through the firewall on the port used 
by the server. This requires adding an Inbound Rule to the Windows Firewall on the computer where 
the tag server is installed.

NOTE: If you are using groov Server and it is installed on the same computer as the OPC-UA server, you do 
not need to configure the Windows Firewall as described here. 

As an example, the following instructions describe how to add in Windows 7 the Inbound Rule for 
port 49320, the default port for the KEPServerEX 5 server. 
1. After you have successfully installed the Kepware server, open the Windows Control Panel.
2. If icons are displayed in the Control Panel, click Windows Firewall. If categories are displayed in 

the Control Panel, click System and Security and then click Windows Firewall.
3. In the left panel, click Advanced settings.

New dynamic tag
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The Windows Firewall with Advanced Security dialog box opens.

4. In the left panel, click Inbound Rules.

5. In the right panel, click New Rule.

6. For Rule Type, select Port. Click Next.

7. For Protocol and Ports, select Specific local ports and enter 49320 (the default Kepware port). 
Click Next.
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8. For Action, select “Allow the connection.” Click Next.

9. For Profile, select Domain and Private. Click Next.

10. For Name, enter a descriptive name such as “Kepware OPC-UA Server.”
11. Click Finish.
12. Exit the Windows Firewall and Control Panel dialog boxes.

Editing a Controller’s or OPC-UA Server’s Address
If a controller’s or OPC-UA server’s hostname or static IP address has changed, you’ll need to edit the 
hostname or address in Build.
1. Select Configure > Devices and Tags.
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2. Click Edit Address.
3. For an Opto 22 controller, enter a new IP address or hostname, then click OK.

For an OPC-UA server, enter a new name or server URL, then click Update Server.

4. Close the Configure Controllers dialog box.

Deleting a Controller or OPC-UA Server
You can a delete a controller or OPC-UA server from your project. However, be aware that any tags 
associated with gadgets will be lost and have to be reassigned.
1. Select Configure > Devices and Tags.

2. Click Delete
3. Click OK.
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4. Close the Configure Controllers dialog box.

Adding Gadgets
There are two basic methods for adding a gadget and associating a tag. You can start with gadget 
and add a tag to it. Or, you can start with a tag and then add the tag’s gadget.

Method 1: Add a Tag to a Gadget
Drag a gadget from a toolbox onto the page, and then assign it a tag.
1. Select the Gadget tab in the Gadget Palette.

2. Either double-click a gadget or drag it to the work area.
3. Select the gadget in the work area, and then click None Selected in Gadget Properties.



CHAPTER 2: BUILDING AN OPERATOR INTERFACE

groov User’s Guide 2727

This opens the Update Tag for Gadget dialog box.

4. Browse to the tag you want to use, select it, and then click Update Gadget.
5. Configure the gadget’s properties. See “Configuring Gadgets” on page 28.
6. Select File > Save All Changes.

Method 2: Add a Gadget to a Tag
Click a tag and assign an available gadget.
1. Click the Tags tab in the Gadget Palette area, expand the tag’s category, and then click the tag.

Gadgets appear that work with the selected tag.

Expand the tag’s 
category

Click the tag
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2. Either double-click a gadget or drag it to the work area.
3. Configure the gadget’s properties. See the next section, “Configuring Gadgets.”
4. Select File > Save All Changes.

Configuring Gadgets
Once you have added a gadget and assigned it a tag, then you can resize or move it, and change the 
gadget properties.

• To move the gadget, grab it with the left mouse button and drag it.

• To resize the gadget, grab a graphic handle and drag to the new size.

• To change other gadget properties, click the gadget.

Change the properties as desired. For example, if you use the LED’s default blue color, the LED 
will be bright blue when it’s on and black when it’s off. And you can type in a label.

Resize

Move

LED on

LED off

/internal/wiki/FsDisplay#Gadgets
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Available Gadgets

Group Header

Use the Group Header gadget to define a group of objects. In Gadget Properties, enter a group 
name and select a font size. 

TIP: If you need to move a Group Header (or any other gadget) behind another gadget, right click the 
gadget and select Send to Back.

Here are the gadgets you can use in your Build project.

TIP: When adding text to a gadget, in addition to basic ASCII, you can also use the extended character set. 
See “Appendix D: Extended Character Set” on page 79.

Gadget Go to
page 29

page 30

page 30

page 30

page 31

page 31

page 31

page 32

page 32

page 33

page 33

page 34

page 34

page 35

page 35

page 36

page 37

page 38

Group Header gadget

Other gadgets

Choose the text size

Enter a label.
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Line Header

Use the Line Header gadget to provide a label for organizing objects on a page.

Divider

The Divider gadget provides a horizontal or vertical line to separate groups of objects. For a vertical 
line, choose Vertical. You can make the divider longer or shorter by selecting the object and 
dragging its handles.

Page Navigator
Use the Page Navigator gadget to provide a link to another page in the project. Select a target page. 
If there are a lot of pages, type the name of the page (or part of the name) in the search box.

Enter a label.

Choose the horizontal placement and 
Bold or Italic for the label.

Check this box for a line under the label.

Horizontal or vertical

Search for the page name

Select the target page

Page navigator gadget
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Video

The Video gadget displays an iFrame type video stream from an IP camera. This gadget does not 
interact with controller points/variables. For information on IP cameras and how to enter a URL, see 
“Appendix B: Network Cameras” on page 73.

Image
Use the Image gadget to place an image in your project. Click Select Image to browse to the image 
file location. For best performance, use images no larger than 2000 x 2000 pixels at 72 dpi with 8 bit 
color information, or a total of less than 300 KB in size.

When using animated GIFs, consider how to use it effectively in your HMI. Also, limit the file size to 
less than 300 KB, especially if the page you are building will be viewed on a smartphone that has 
reduced memory.

LED

An LED is a read-only gadget that indicates the on or off state of a numeric value. The LED is off 
when a tag’s value is 0. It’s on when the value is non-zero.

Select a tag, enter a label, and select a color for the true (on) and false (off ) states.

Enter the URL of an IP camera.

Video

Click here to browse 
to the image file

Image gadget
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The on and off states for a blue LED look like this:

Checkbox

The Checkbox gadget is a read/write binary input which your user can toggle on or off by selecting 
the box. Off = Zero, On = non-Zero. 

 

Button
The Button gadget is a read/write binary input which your user can toggle on or off by clicking it. 
Off = Zero, On = non-Zero. Select a color for the true (on) and false (off ) states.

LED on

LED off

Select a tag

Enter a label

Select the on color

Select the off color

Select a tag

Enter a label

Select Confirm to display a 
Confirm Send dialog box

Checkbox gadget

Select a tag

Enter a label

Select Confirm to display a 
Confirm Send dialog box

Select the on and off colors

Configurable
color

Button off

Button on
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Command Button

The Command Button gadget sends a value to a numeric or string variable. You can configure the 
button’s color, and you can resize the button and the text by selecting the box and then grabbing 
and dragging the object’s handles.

Horizontal Slider

The Horizontal Slider gadget is a read/write gauge that displays an analog or float-type value using a 
bar that fills to indicate the present position or value. This is the same as the horizontal gauge except 
that your user can interact to change the value and write it to the controller by grabbing and 
moving the indicator button. You might use this gadget for room temperature setpoints, alarm 
values, PID settings, and so on.

Select a tag

Enter a label

Select Confirm to display a 
Confirm Send dialog box

Enter a value

Select the button’s colorCommand button gadget

Value

Color

PrecisionLabel

Button

Click here to choose a tag.
Enter a label.
Enter the minimum and maximum values that can be displayed.

Enter the number of places to the right of the decimal 
point to be displayed.
Choose the color of the indicator.

Select Confirm to display a confirmation 
dialog box when your user moves the slider.

When checked, the gadget continually writes values 
as the slider is dragged. When unchecked, it writes 
only one value when your user lets go.

From drop-down list, choose Show Value, Show Percent, or None.
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Horizontal Gauge

The Horizontal Gauge gadget is a read-only gauge that displays an analog or float-type value using 
a bar that fills to indicate the present position or value. It displays a numeric value in a horizontal 
gauge. You might use it for a fuel gauge, a noise-level indicator, etc.

Text Area

The Text Area gadget is a read-only output for displaying numerical or string data. Enter text just as 
you want it to appear, and use enough pound signs (#) to display data. For example, ##.# might 
display 35.0, and ###.## might display 350.86. The data will be blue, but any other text will have the 
color you assign to it. You can also change the background color.

Value

Color

PrecisionLabel

Click here to choose a tag.
Enter a label.
Enter the minimum and maximum 
values that can be displayed.

From drop-down list, choose Show 
Value, Show Percent, or None.

Enter the number of places to the right of the 
decimal point to be displayed.

Choose the color of the indicator.

DataText

Background

Click here to choose a tag.

Type a label and put 
enough pound signs (#) to 
display the tag’s value.

Format the text.

Select the text and 
background colors.
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Text Input

The Text Input gadget is a write-only field that your user can change to send numerical or string 
data to the controller.

Text Inputs are linked with a Send/Submit button that is automatically generated on the page for 
each Edit Box. Text changes are sent when the Send/Submit button is pressed. 

Value
The Value gadget is a read-only output for displaying numerical or string data. It has a uniform width 
to make it easy to line up multiple gadgets. The text format changes depending on the tag type so 
you don’t have to configure it manually. For example a float type tag will have #.##, whereas an 
integer tag will have just #. In the Label text box, enter text just as you want it to appear. The data 
will be blue, but the label text will be black.

Label

Value

Choose a tag.

Select a text box size. If you select 
Unlimited, you cannot enter a label.

Provide the minimum and maximum 
values that your user can enter.

Format the text.

Enter pre and post prompts for 
the Edit Textbox Value dialog.

Select this box to display a confirm dialog 
when your user enters a new value.

Enter a label.

DataLabel

Click here to choose a tag.

Choose the field width.

Format the text.

Enter a label.
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Round Gauge

The Round Gauge gadget is a read-only gauge that displays an analog or float-type value using a 
rotating needle and decimal numerical display to indicate the present position value. A configurable 
string indicates the units that the gauge is displaying, for example, “km/h,” “Gallons,” etc. Possible 
uses include water or gas pressure gauges, the speed of a conveyer belt, etc.

Major Interval: Enter the interval for numerical markers. If you use the default (0), markers will not 
be shown, although the end-points for the range are always displayed. If an interval creates more 
than 500 tic-markers, only the end-markers being displayed.

Minor Interval: Enter the interval for small tic-markers. If you use the default (0), markers will not be 
shown. If an interval creates more than 500 tic-markers, the markers will not be shown.

Current ValueUnits

Zone-1 color

Needle color

Max Value
Min Value

Zone-1 Start Value

Zone-1 End Value

Click here to choose a tag.

Enter the gauge’s minimum value.
Enter the gauge's maximum value.

Select the needle’s color.

Enter the number of places to the right of the 
decimal point to be displayed.

Enter a unit’s label.

Enter the start and end values for this zone. These must be 
not more or less than the gauge’s Min and Max values.

Select Show Value to display the decimal value in the gadget.

Click here to add another zone.

Choose the zone color.

Click here to delete this zone.

(Optional) Override the default tic marks. Enter a new Major 
Interval and Minor interval. See the descriptions below.

Gauge terminology

Zone terminology
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Range Indicator

Use the Range Indicator gadget to show on a horizontal or vertical scale where data appears in a 
range of numbers. This gadget is commonly used as a thermometer. But it can be used to indicate 
any kind of data within a range. By arranging several of these together on page, an operator can tell 
at a glance if a machine is operating correctly.

Zone color

Major tics

LabelValues

Units

Minor tics

Choose a tag.

Enter the minimum value.
Enter the maximum value.

Enter the number of places to the right of the 
decimal point to be displayed.

Enter a label.

Enter the start and end values for this zone.

Enter the units (for example, degrees, GPM, PSI)

Click here to add another zone.

Choose the zone color.

Click here to delete this zone.

Enter Show Value, Show Percent, or None.

Select Vertical if you want a vertical range indicator.

Use these settings to override the default tic marks. See 
the descriptions below.

Select this option for visible markers.

Gauge terminology

Zone terminology
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Major Interval: Enter the interval for numerical markers. If you use the default (0), markers will not 
be shown, although the end-points for the range are always displayed. If an interval creates more 
than 500 tic-markers, only the end-markers being displayed.

Minor Interval: Enter the interval for small tic-markers. If you use the default (0), markers will not be 
shown. If an interval creates more than 500 tic-markers, the markers will not be shown.

Plot
Use the Plot gadget to create a graph that shows how a variable is changing over time. A plot starts 
graphing when you open the page it is on. The current version of groov does not support historical 
graphing.

Cutting and Pasting Gadgets
If you want to cut or copy a gadget, right-click it to open the popup menu, and then select Delete, 
Duplicate, Copy, or Cut. To paste a copied or cut gadget, left-click the workspace, right-click, and 
select Paste from the popup menu. As indicated on the pop-up menus you can also use keyboard 

Fill

TimeY-Axis label

Chart title

Choose a tag.
Choose a regular or smoothed line.

Click here for a filled graph.

Enter the Y-Axis label. To enter a degree symbol, see Appendix D

Choose Set By Operator to have the end user set the Min and 
Max values. Detected By Graphs sets the Min and Max for the 
end user. (See the note below.)

Choose the color of the line and fill.

Choose Small, Medium, or Large text.

Enter the time period to display in minutes up to 60.

Enter the chart title.

Choose the Min and Max values displayed.

NOTE: For the Value Limits property, Detected By Graph only 
works if the Show Graph Fill property is not selected.
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shortcuts for Copy (CTRL + c), Cut (CTRL + x), and Paste (CTRL + v). You can hold down the CTRL key to 
select more than one gadget at once.

Moving a Gadget to the Front or Back
If gadgets overlap and you want to change the order of the stack, right-click a gadget and select 
Bring To Front or Send To Back. If you don’t want a gadget to move, choose Lock Position.

Viewing the Tags in Use
To see and edit all the tags being used in your project, select View > All Tags. The Tags in Use dialog 
box shows the tags in use and the associated controller or OPC-UA tag server, page, and gadget. 
Click the page button to navigate to the page the gadget appears on. Click a column heading to 
sort. For example, to see everything on one controller, click the Controller heading.
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Optimizing Layouts
In groov Build there are two different layouts: Desktop & Tablet and Handheld. The Desktop & Tablet 
layout allows you to organize the gadgets for viewing on a computer monitor or a tablet. The 
Handheld layout is for viewing on a handheld device such as a smartphone.

For any given page, both layouts contain identical gadgets and properties, but you can resize or 
move a gadget in one layout and not affect the gadget’s size or position in the other layout. This way 
you can move the most important gadgets to the top when seen on a smartphone.

groov uses the appropriate layout for the device being used. Or, if you have groov View for iOS or 
groov View for Android on a mobile device, you can choose which layout to view.

To work on a layout:
1. Click either Desktop & Tablet or Handheld at the top of the page.

Desktop & Tablet layout

Handheld layout

Click tab
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2. Drag each gadget into position, and resize as necessary.

NOTE: If you change the text size for a gadget in one layout, it changes it also in the other layout.

3. Click the other tab and adjust the size and position of the gadgets as necessary for that layout.
4. Select File > Save All or Save All and Switch to groov View.

Drag into position

Resize

Desktop & Tablet view

Handheld view
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Creating a User
1. In groov Build, select Configure > Accounts. Then click the Users tab.

2. Click Create User.
3. Enter a username and password (in both boxes) for the new user.

4. Select a security level (Admin, Editor, Operator, or Kiosk).

For example, if you want a user to be able to log in and out of groov View and change their 
password, choose the Operator security level. on the other hand, if you want to define a user 
who can use View but can’t log in or out, or change their password, choose Kiosk.
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This table shows the privileges available for each security level:

5. Select the groups the user belongs to.

Groups are used to restrict access to particular pages for Operator and Kiosk level users. If a 
page is restricted to members of the group called West Wing, then a Operator or Kiosk level user 
must be in the West Wing group to access that page.

6. Click OK.

Changing a User’s Security Settings
1. In groov Build, select Configure > Accounts, then click the Users tab.
2. Highlight a username and click Edit User.

Security Level

Admin Editor Operator Kiosk

Pr
iv

ile
ge

Use and interact with the gadgets in 
groov View * *

Log in and out, and change the password 
in groov View* *

Use groov Build to import strategies, 
make pages, and set groups on pages

Create users and groups, and assign 
users to groups

* For the groups an Operator or Kiosk user belongs to.
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3. If needed, change the security level (Admin, Editor, Operator, or Kiosk).

4. If needed, change the groups your user belongs to. See the table on page 43.
5. Click OK.

Managing User Groups
To add or edit a group, in Build select Configure > Accounts. Then click the Groups tab.
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Create Group. Enter the Group Name, and select the users to be included in the group. Check 
the pages this group should see.

Edit Group. Highlight a group and then click this button. Select or deselect the users to be 
included in the group.

Delete. Highlight a group and click this button, and then click OK.

Resetting a User Account Password
When you reset a password, a new password is generated automatically. This can be useful if a 
password is lost. To create a specific new password, see “Changing the Current User’s Password” on 
page 46.

Your user will need to enter this new password the next time they log in. The password is case 
sensitive.
1. In groov Build, select Configure > Accounts. Then click the Users tab.
2. Highlight a username and click Reset Password.
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A message appears that your user will need to enter this new password the next time they log 
in. The password is case sensitive.

3. Click OK.

A dialog box appears with a new temporary password. Give this password to the user.

4. Click Close, and then click Close again.

Deleting a User Account
1. In groov Build, select Configure > Accounts, then click the Users tab.
2. Highlight a username and click Delete. The deleted user will no longer be able to log in.

A confirmation message appears.

3. Click OK to confirm.

Changing the Current User’s Password
You can change the password for the current user in either Build or View mode, or the user can 
change their own password in View. Your user will need to enter this new password the next time 
they log in. See also, “Resetting a User Account Password” on page 45.
1. In Build mode, select Security > Change Password.
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In View mode, click the gear icon and select Change Password.

2. Fill in the form with the old and new passwords, then click OK.

3. Tell the user the new password.

Changing the Project Settings
1. Select Configure > Project.

2. Choose Project Settings options:

– Show page list in groov View—If you deselect this option, a user using View can only see 
the first viewable page. All other pages will not be available to view.

– Show logo in groov View—Deselect this option to hide the groov logo.

– Video Update Period—Enter how often in seconds a video gadget will update the video 
feed. The default is 0.5 seconds, the fastest setting possible. The Video Update Period 
applies to all video feeds in your groov project.
If you have a fast Internet connection and are not concerned about data use, then you can 
use the fast setting (0.5 seconds) for a smoother video. However, if you have a slower 
connection, the video might not be able to keep up, and you should enter a higher value 
so the video updates less frequently. Also, if you have a data use cap, you should probably 
increase the time between updates.
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Saving Your Project and Opening groov View
Click the File menu and select one of the following.

Save All Changes. Saves your latest changes, but it does not update any open iterations of View.

Save All Changes and Switch to groov View. Saves your latest changes and opens an updated 
groov View.

Switch to groov View. Opens groov View without incorporating any changes you have made 
since your last save.

Open groov View in New Tab. Use this option if you want to have both groov Build and View 
open at the same time in separate tabs.

Backing Up and Restoring Your Project
To back up your project, select File > Backup Project to Computer. A backup file is saved to your 
computer.

To restore your project from a backup file (groov Server only):

NOTE: This feature is only available with groov Server. If you have a groov Box, see form 2077, the groov Box 
User’s Guide to restore your project using groov Admin.

CAUTION: Only restore your project if you have to. You will lose all work done since the last backup, and 
all users will be logged out.

1. Select File > Restore Project from Computer.

http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4382
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2. In the Restore Project dialog box, browse to the Windows Download directory to locate the 
tar.gz backup file.

3. Enter the username and password for the Admin account.
4. Click Restore.

The following warning appears.

5. If you are sure you want to proceed, click OK.

When the restoration process is complete, the restored project opens in groov View.

Getting groov Updates
You are eligible to receive groov updates as long as your license is active. Updates add new 
capabilities and fix issues that may arise.

Each groov installation is treated independently, so you must activate each one; updates are valid for 
a specific groov installation only.

To check for updates, go to manage.groov.com.

To install an update, download the update file and then run the installation.

Updating Your License
In order to use updates for groov, your license must be up to date.

To check the expiration date, select Configure > Licensing. The expiration date appears below 
Enabled Features.

http://manage.groov.com/
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To update your license:
1. Go to manage.groov.com and follow the on-screen instructions to purchase continued 

maintenance and acquire a new license file.
2. Save the license file to your computer.
3. Select Configure > Licensing.
4. In the License Management dialog box, click Select License File.

5. Browse to the new license file, highlight it, and then click Open.
6. The message, Upload Successful, appears on the License Management dialog box.
7. Click Close.

License agreement 
expiration date

http://manage.groov.com/
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3: Chapter 3

3: Viewing Your Operator 
Interface

The operator interface developed in groov Build resides on a groov Box or on the groov Server and 
can be accessed in a computer’s browser, or on a smartphone, tablet, or other mobile device that 
has a modern browser.

In this chapter:
Opening View .................................................................................. 51
Opening a Page............................................................................... 52
Logging Out...................................................................................... 52
Changing Your Password ............................................................ 53
Refreshing the Operator Interface .......................................... 53
Using a groov View Mobile Device App............................... 54
Using groov over the Internet................................................... 57

Opening View
1. Open your web browser or mobile device app (groov View for iOS or groov View for Android).

For groov Server:

– If groov Server is installed on the same computer, type https://localhost in the 
address bar of your browser.

– If groov Server is installed on a different computer, type https:// and the computer’s 
hostname. For example, if the computer’s hostname is RStarr-w7, you type 
https://RStarr-w7

You can use the IP address of the host PC instead of the hostname. However, if the PC is on 
a network with DNS and DHCP, the IP address is subject to change.

Make sure you type the s: https://

For groov Box:

Type https:// and the groov Box’s hostname or IP address as the URL. The hostname is printed 
on the top of the groov Box. (Your hostname will be different from this example.)



OPENING A PAGE

groov User’s Guide52

For example, if the hostname is opto-06-ac-6f, you type https://opto-06-ac-6f

Make sure you type https. The s indicates it is a secure connection.

NOTE: If you’ve assigned a static IP address to the groov Box, use the IP address instead of the 
hostname to open groov.

2. Log in with your username and password.

Opening a Page
1. Click the navigation icon in the upper left of the screen.

2. Expand the page’s category.
3. Click the link.

Logging Out
1. Click the gear icon on the top right-hand side.

Default 
hostname

Icon

Category

Link
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2. Click Log out ‘Username’.

The login dialog box appears.

Changing Your Password
1. Click the gear icon on the top right-hand side.
2. Click Change Password.

3. Enter the current password and the new password two times.

4. Click OK.

Refreshing the Operator Interface
If the operator interface has been changed and saved, you can easily get the latest version. When 
you refresh View, the new changes appear.
1. Click the gear icon on the top right-hand side.
2. Click Refresh groov View.
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Using a groov View Mobile Device App
The free groov View apps for iOS and Android allow you to use View for one or more groovs on your 
smartphone or tablet in full-screen mode without the address bar, toolbars, and other things you 
see in a browser. To get a groov View app for your mobile device, go to your app store and search for 
“groov View.”

To connect to groov the first time:
1. Install the groov View app on your iOS or Android device.
2. Tap the groov icon to start the app.

Connecting to groov in Android
1. Tap Connect to groov...

A prompt appears.

2. Type https:// and groov’s hostname or IP address as the URL.

Using the iOS App
“Adding a groov to a groov App for iOS” (below)

“Connecting, Editing, and Setting a groov as the Default” on page 55

“Using the iOS groov Settings” on page 57

Adding a groov to a groov App for iOS
Follow these steps in your iOS app to connect to groov the first time or whenever you want to add 
another groov.
1. Tap the groov icon to open a list view for adding one or more groovs.
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2. Tap  to open the configurator.

3. Enter the following information.

– Hostname—Type https:// and groov’s hostname or IP address.

– Port—Enter the port number, usually 443.

– Username and Password—Enter the username and password for this groov.

Additional Options

– Full Screen—Enable this for more space on the screen.

– Passcode—When enabled, the next time you connect to this groov, you will be prompted 
to enter a new passcode which will need to be entered each time for this groov on this 
device.

4. Tap Done.

Connecting, Editing, and Setting a groov as the Default
Follow these steps in your iOS app to connect, edit the configuration settings, or set a default groov.
1. Start the groov app to open a list of groovs. 

If you haven’t connected a groov, see “Adding a groov to a groov App for iOS” on page 54. If you 
have set and enabled a default groov, groov View opens instead. In this case, swipe right to 
return to the list view.
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2. Tap a groov in the list to open its groov Options.

– Connect—Connects to the selected groov.

– Edit—Opens the configurator for the selected groov for you to edit the connection 
settings. The configurator screen screen is filled with the data from the selected device, and 
the title is the hostname or IP address of the device.

– Set as Default—Sets the selected groov as the default so that when you start the groov 
app it bypasses the list view and opens the default groov automatically in View. For this to 
work you also need to turn on Enable Default Device in the iOS Settings. See “Using the iOS 
groov Settings” on page 57. Only one device can be the default.

– Cancel—Exits groov Options.



CHAPTER 3: VIEWING YOUR OPERATOR INTERFACE

groov User’s Guide 5757

Using the iOS groov Settings

To configure the following settings in iOS, open the Settings app and tap groov.

• Hide Status Bar—ides the status bar that normally appears at the top of the screen.

• Enable Kiosk Mode—In Kiosk Mode the user cannot return to the list view with a right swipe.

• Enable Default Device—Use this option if you want to bypass the groov list when starting 
and go directly to the default groov. You will also need to assign a default groov in the groov 
Options. See “Connecting, Editing, and Setting a groov as the Default” on page 55.

Using groov over the Internet
If you’re using a PC or mobile device to communicate with groov over the Internet rather than from 
inside your local area network, you can use either a VPN or port forwarding. However, a VPN is 
strongly recommended because it is much more secure. Talk with your IT Department to get a VPN 
set up. For more information on a VPN and port forwarding, see form 1796, the Guide Networking 
Opto 22 Products.

With a less-secure port forwarding connection, groov uses the following ports:

Port For communication with

443 or 8443 groov Build and groov View (443 is the default)

10000 groov Admin (applies to groov Box only)

http://www.opto22.com/site/documents/doc_drilldown.aspx?aid=4401
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f4: Chapter 4

4: Troubleshooting and 
Additional Help

This chapter provides troubleshooting information and answers questions you may have about 
groov.

In this chapter:
Troubleshooting.............................................................................. 59
Basics.................................................................................................... 64
Getting Started ................................................................................ 66
Working with groov....................................................................... 59
Opto 22 Systems............................................................................. 68

Troubleshooting
Q: In groov View on my laptop/HDTV/phone/tablet, all I see is a blank page.
What's the matter?
A: Two possibilities:

• Your web browser may not fully support the modern standards groov is based on. Try 
downloading the latest version of your browser. Or try a different browser. We generally 
recommend Firefox or Chrome, but your device might work better with Safari or Internet 
Explorer.

• You may be logged in as a user who doesn’t have access to any pages. Go to groov Build and 
check your users and groups to make sure the user has access. See Chapter 2: Building an 
Operator Interface for help.

Q: In groov View on my mobile device, I can't get the pages to load. 
How do I get to them?
A: First, make sure you have at least the minimum OS for your device:

• Android: 4.0.1 (Ice Cream Sandwich)

• iOS: 5.0

If you’re still having problems, don’t worry. We’ve seen some quirks depending on your device and 
browser. Here are some things to try.

• Try adding your own company domain to the hostname of the groov Box or groov Server PC. 
Sometimes the DNS (domain name server) won’t resolve the hostname unless you add your 
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domain. Example: instead of https://opto-02-81-c2 try https://opto-02-81-c2.opto22.com 
(Your domain will be different. Note the period between the hostname and domain.)

• Try adding the port number to the hostname. Port 443 is the default; port 8443 is the 
secondary, so try them in that order. For example: instead of https://opto-02-81-c2 try 
https://opto-02-81-c2:443 (Note the colon between the hostname and port.)

Q: I'm in groov View, and some of the gadgets are grayed out with a yellow triangle. 
What's going on?
A: If a gadget is grayed out with a yellow triangle, either your HMI isn’t communicating with groov, 
or groov isn’t communicating with the controller or tag server, or the tag server isn’t communicating 
with the control equipment.

Click the yellow triangle to display an information dialog box.

If the information dialog says that a tag is not available on the controller, make sure the strategy 
running on that controller matches the idb.txt you have associated with that IP address.

Once you’ve fixed communications, groov View will automatically restore the gadget to working 
order.

NOTE: The groov Box or groov Server polls the controller tag server for data once per second. This frequency 
cannot currently be changed.

Q: In groov View, some of the gadgets are grayed out with a manilla tag. 
What does this mean?
A: If a gadget is grayed out with a no-tag symbol, the gadget does not have a properly configured 
tag associated with it.

Once you’ve configured a tag for the gadget, groov View will automatically restore the gadget to 
working order.

Q: In groov Build, I can’t see the dialog box buttons. 
How do I make them visible?
A: If you can’t see dialog box buttons, your browser’s font size may be set too high. Reduce the 
browser’s font size so that you can see the buttons.

Q: I have groov Server and I’m not able to open groov. What should I do?
A: There might be a conflict with another service running on your computer. In this case, you might 
need to change one or both of the ports groov Server uses to run.

To change a port number, first consult with your IT manager, and then do the following:

Click the yellow 
triangle

No-tag symbol
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1. Open the jetty.conf file installed on the groov Server computer. You’ll find the file in 
Opto22\groov\jetty.

2. Change the port as necessary.
3. Save and close the file.
4. Restart groov Server and try again.

To restart groov Server:
5. Open the Windows Control Panel and click Administrative Services.
6. Select groov Server.
7. Click Restart.

Q: I have a groov Box and a Windows computer, and I’m not able to locate my 
groov Box on the network. What should I do?
A: If you are using a Windows computer, you can use groov Find to locate the groov Boxes on your 
network. You must use groov Find if your network does not have DNS.
1. Insert the groov CD in your CD-ROM drive, then click the link to copy the Find application file to 

your computer.
2. Open the Find application file.

If you have User Account Control (UAC) turned on, a message appears asking if you want Find 
to be allowed to make changes to your computer. Click Yes.

Click Restart
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NOTE 1: If you are using a Windows account that does not have Administrator privileges (such as 
Guest), you will need to enter the Administrator User Name and Password in order to use groov Find. 
If you do not have this information, contact your IT department.

NOTE 2: Clicking Yes permits Find to have temporary administrative privileges to create an additional 
temporary IP address for each network interface on the computer. This enables Find to locate a groov 
Box on a network that does not have DNS and DHCP. If the network does not have DNS and DHCP, you 
will need to assign a static IP address to the groov Box in order to maintain communication. (See the 
groov Box User’s Guide.) If the network does have DNS and DHCP, the temporary IP address is not used 
and is removed when you exit Find.

groov Find opens and automatically searches for groov Boxes on the network.

3. Find the serial number on the top of the groov Box.

4. Locate the matching serial number in Find.

Serial number
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If you do not see the serial number right away, wait 60 seconds and click Search for Devices.

5. Click the link “Click to start groov.”

Q: I’m having trouble using Internet Explorer 10 with groov. What should I 
do?
A: You can try Chrome or Firefox instead if those browsers are available. But if you want to use 
Internet Explorer 10, do the following steps to make sure the browser is not reverting back to version 
9 mode; groov is not compatible with Internet Explorer 9.
1. Open Internet Explorer 10.
2. If the menu bar is not already showing, right-click anywhere in the top border of the browser 

and select the Menu bar option.

3. Open the Tools menu, and make sure that Compatibility View is not selected.

LinkSerial number

Make sure this is option 
is not selected.
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4. Select Tools > Compatibility View settings.
5. In the Compatibility View Settings dialog box, make sure that no groov IP addresses or 

hostnames are listed under “Websites you’ve added to Compatibility View.” 
6. Also, make sure that the compatibility options at the bottom of the dialog box are not checked.

7. Click Close

Basics
Q: Can I use a groov operator interface on my Android smartphone? my Mac 
laptop? my Linux computer? my MS Surface? my iPhone5?
A: Yes, yes, yes, yes, yes. You can use your groov HMI on virtually any device with a modern web 
browser, from an iPod touch all the way up to a browser-enabled high-definition TV.

That’s because the HMI runs in the browser, and most modern web browsers adhere to open 
standards like HTML5, CSS3, and SVG. Using those standards without plugins, groov makes it 
possible to run your HMI on almost anything you want to use.

Minimum operating systems for mobile: Android 4.0.1 (Ice Cream Sandwich), iOS 5.0, Surface 
Windows 8.

Q: Does groov support different screen proportions, like 16:9 or 4:3?
A: Yes. groov supports all screen sizes, shapes, and proportions. The elements in your HMI flow to fit 
the shape of the screen.

Make sure these 
options are not 
checked.

Make sure no groov IP 
addresses or hostnames 
are listed.
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Q: How safe is groov in terms of information security?
A: groov uses the same SSL (Secure Sockets Layer) as your bank: 256-bit encryption.

Q: You say I can use any modern web browser with groov. 
What does that mean?
A: Browser-based groov works reliably on a huge number of device, operating system, and browser 
combinations. Thanks to standards like HTML5, SVG, and CSS3, modern browsers are now more 
similar than they are different. We’ve seen groov work beautifully on HDTVs, phones of many shapes 
and sizes, and numbers of new devices, which we try out as fast as we can get our hands on them.

Have we tested every device, OS, and browser available? Of course not. And they’re constantly 
changing. Fortunately browsers are free and download quickly, so if one doesn’t give you the results 
you like, it’s easy to try another. If you’re having concerns, please share them with us.

Q: Can I use groov to build an HMI for my PLC system?
A: Absolutely! You can build an interface to monitor and control almost any automation system or 
equipment: Rockwell Automation/Allen-Bradley, Siemens, Wonderware, Schneider, Honeywell, 
Yokogawa, GE, Modbus, and many more.

We recommend Kepware Technologies’ KEPServerEX as your communication platform. Huge 
numbers of drivers are available. Check the full list at 
www.kepware.com/Products/products_OPCServers.asp.

The cool thing is that you can build a groov operator interface to monitor and control everything on 
this list, even putting different systems or equipment in the same interface. You have the flexibility 
to design the interface you need.

Q: How can groov connect to all these automation systems?
A: It's simple: groov is built on industry standards rather than proprietary standards. groov operates 
as an OPC-UA client. If you have a communication platform like KEPServerEX, which includes an 
OPC-UA server, groov can talk to any driver you’ve purchased for the platform. That opens up a huge 
number of industrial automation systems, building automation systems, energy systems, and more.

Bottom line, your operators and other authorized users will be able to see pretty much whatever 
they need to in order to do their jobs better, save time, and keep equipment and processes in top 
condition.

Q: I’m a machine builder. What does groov do for me?
A: groov gives you an easy way to build an interface to your machine. And depending on where 
your machine is used (obviously not in harsh conditions), now you can use off-the-shelf commercial, 
networkable touchscreens (anything with a modern web browser) as the operator interface to your 
machine.

The easiest way to do this is to get the free groov View for iOS app for an iPad, iPhone, or iPod touch. 
Once your HMI is running on the app, use Apple’s Guided Access feature to put the device into kiosk 
mode. Guided Access restricts the device to a single app, disables the hardware buttons, and keeps 
the device from sleeping, effectively providing a low-power, low-cost, wireless, touch-screen 
operator interface locked down for an intended use only.

Q: How often is the data from my control system updated?
A: Your interface in groov View polls the controller or tag server once per second, so you’ll see the 
live data in blue text updated every second. Currently you can’t change this rate.

http://www.kepware.com/Products/products_OPCServers.asp
http://www.kepware.com/Products/products_OPCServers.asp
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Getting Started
Q: What’s the hostname?
A: The hostname is the name your network a groov Box or other devices, like computers, on your 
network. The default hostname for a groov Box is on the label on the Box. For groov Server, the 
hostname is the name of the groov Server PC on the network. To get to groov, you type https:// and 
the hostname in your web browser.

Example for a groov Box: If the hostname on a groov Box label is opto-02-2b-a6, you open a browser 
and type: https://opto-02-2b-a6

Example for groov Server: If the hostname of the PC where groov Server is installed is win8-server, 
you open a browser and type: https://win8-server.

Notice for both examples that you have to type https, not just http. The “s” indicates it’s a secure 
connection.

You can change the hostname from the default to whatever you want to use. See “Editing a 
Controller’s or OPC-UA Server’s Address” on page 24.

Q: Why are there two passwords for the groov Box?
A: When you first set up the groov Box, you have to enter two username and password 
combinations. That’s because they’re for two separate purposes:

• One is for administering the groov Box using groov Admin. Here you do things like change 
network settings or check the status of the Box.

• The other is for building and viewing your operator interfaces using groov Build and groov View. 
Here you’ll also set up usernames and passwords for the other people in your company who 
will be using groov.

For system security, it’s extremely important that you guard these login credentials carefully. Treat 
them as if they were passwords for your bank account. And don’t lose them. Since they cannot be 
retrieved, you will lose your work if you lose them.

Q: Is it possible to back up my groov HMI project?
A: Absolutely, and it’s really important that you do so. See the Chapter 2: Building an Operator 
Interface for backup and restoration steps.

Q: How does groov get my tag database?
A: For an Opto 22 system, you open groov Build in your browser and point it to two things: the 
hostname or IP address of your SNAP PAC or OptoEMU Sensor, and the strategy.idb.txt file (see next 
question).

For all other automation systems, you open groov Build in your browser, point it to your tag server 
(we recommend the KEPServerEX communications platform), and import your tag database.

With just these two pieces of information, the groov Box knows how to connect to your system, 
either to get data or to send data.

If you make changes to your tag database, import the tags again (or for an Opto 22 system, point 
groov to the .idb.txt file again) so you can use the changed data in groov.
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Q: What’s the strategy.idb.txt file and where do I find it?
A: For an Opto 22 system, your SNAP PAC controller is running the control program (strategy) you 
built in PAC Control. When you saved that strategy, the .idb.txt file was automatically created on your 
PC. It’s a simple text file that includes all the tags in your tag database: I/O points, variables, and 
more. The groov Box stores this file and reads the tag information in it.

You’ll find the .idb.txt file on your PC in the same directory as your other strategy files. If you’re using 
groov with an OptoEMU Sensor, you can get the OptoEMU Sensor.idb.txt file on opto22.com.

Btw, some computers have common file type extensions hidden. Since .txt is a common file type, 
your computer might be hiding the extension from you, in which case you will see two files with the 
same name, the name of your strategy. Just select the file that does not have the PAC Control icon 
next to it.

Q: Can I VPN directly into my groov Box?
A: No, the groov Box is not a VPN server, which is required if you want to use VPN to communicate 
with groov. Find out if your company network has a VPN server. Many do, usually to let employees 
safely access the network from home or a remote site. Most smartphones have a VPN client built 
into them. For more information, see form 1796, the Guide to Networking Opto 22 Products.

Working with groov
Q: How do I build an HMI?
A: It’s easy:
1. On your computer, open a web browser and log into groov Build. On the left under Pages, click 

Add Page.
2. In the lower-right corner of the screen, open your Tags tree. Choose a tag, pick a gadget from 

the list, and drag it onto the page. In the upper-right corner of the screen, assign gadget 
properties (labels, colors, etc.) as you wish. Or you can choose the gadget first and then assign a 
tag.

3. Click the Handheld tab to see how the layout will look on a smartphone. You can move things 
around or change their sizes.

4. Save and switch to groov View to see and test your HMI. Remember that live values from your 
system are always in dark blue text.

Q: Can I build an HMI from my smartphone or tablet?
A: Mostly no. Currently you’ll use a computer—or a Windows Surface with Internet Explorer 10 and 
a mouse plugged into the USB port. Phones are mostly too small for the job, but a later version of 
groov will likely support more tablets for groov Build.

Q: Can I use tables in groov?
A: You can select individual elements (indices) of a table. groov supports all of these data types: 
integer, float, and string variables and tables, and analog and digital I/O.
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Q: How do I use timers/PIDs/Scratch Pad in groov?
A: groov supports integer, float, and string variables and tables, and analog and digital I/O. To use a 
timer, elements in a PID loop, Scratch Pad elements, or other data you need in a groov HMI, just 
periodically move the data you want into a variable. Voilá! groov can see and use it.

Q: Can I change more than one tag with a single gadget, or stack gadgets to 
do two things at once?
A: Sorry, no. Currently groov supports only one tag per gadget. And if you stack gadgets, the one on 
top wins: it’s the only one that will be functional.

Q: Can gadgets be restricted to particular operators?
A: Operator permissions are based on a page, so everything on one page must be OK for the 
operator to see and change. If some operators should be able to see a gauge and some should not, 
for example, just create two pages—one that includes the gauge and one that doesn’t. Then assign 
user rights to the pages appropriately.

Q: Can you choose who can edit which pages?
A: At present anyone designated as an Editor can edit all pages on one groov. A second groov would 
give you the option to assign different Editors to different pages.

Q: Is the plot gadget realtime or historical?
A: Realtime

Q: In future versions, will there be historic graphs and reports?
A: While we can’t comment on future features right now, we’re interested in hearing what features 
you need. Note that you can get historic graphs now with most HMIs, including Opto 22’s PAC 
Display. So you can have a full HMI that shows historical trends, plus a groov interface that shows 
current trends for specific items.

Q: Are future releases included in the annual maintenance cost?
A: The Maintenance Plan provides updates and upgrades for the feature set at the time you bought 
your groov. Major new features (which not all customers may want) will probably be sold separately.

Q: How do I get my free updates?
A: First, make sure you activate groov. Go to activate.groov.com and follow the steps. If you have 
more than one groov, be sure you activate each one.

Once you’ve activated and installed your license file, you can get updates at manage.groov.com. 
We’ll also notify you by email when an update is available.

Opto 22 Systems
Q: I'm talking to Opto 22 equipment and I can't find my strategy .idb.txt file. 
Where is it?
A: Your SNAP PAC controller is running the control program (strategy) you built in PAC Control. 
When you saved that strategy, the .idb.txt file was automatically created on your PC in the same 

http://activate.groov.com/
http://manage.groov.com/
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directory as your other strategy files. If you’re now using a different PC, you’ll need to get the .idb.txt 
file from the other computer.

If your computer hides common file type extensions (some do), you’ll see two files with the same 
name, the name of your strategy. Just select the file that does not have the PAC Control icon next 
to it.

NOTE: If you’re using groov with an OptoEMU Sensor, you can get the OptoEMU Sensor.idb.txt file on 
opto22.com.

Q: What’s the minimum PAC firmware requirement for groov?
A: The SNAP PAC controller your groov connects to must be running 9.2 or newer firmware. If you’re 
using groov with an OptoEMU Sensor, you need update file R3.0a or newer.

Q: How many controllers does one groov support?
A: Lots. We’ve tested with large numbers of controllers and tags and have not yet seen any 
performance issues.

Q: If a PAC controller is connected to B3000 serial brains, can I get those tags 
in groov?
A: Yes. If the tag is in the controller, it can be displayed in groov.

Q: Can I use groov with my FactoryFloor system? I have an Ethernet card.
A: Yes, but not directly. groov works with all SNAP PACs running 9.2 firmware or higher (SNAP PAC 
S-series controllers, SNAP PAC R-series controllers, SoftPAC software-based controller), and with 
OptoEMU Sensor energy monitoring units running update file R3.0a or newer.

groov does not work with Opto 22 FactoryFloor, SNAP Ultimate I/O, SNAP-LCSX, or other legacy 
controllers, or pre-9.2 SNAP PACs.

However, it’s still possible to use groov with these legacy systems by installing KEPServerEX with the 
OPC Connectivity Suite. Connect to your FactoryFloor OPC Server (which is an OPC-DA server). Then 
groov (which is an OPC-UA client) connects to KEPServerEX, and you can import your tags.

Normally groov references the names of I/O points in a SNAP PAC controller running a PAC Control 
strategy; groov does not directly access Opto 22 brains. If you have the Kepware Opto 22 Ethernet 
OPC Server, however, you can add tags to connect directly to I/O.

Q: Can I use groov to access I/O points on my SNAP PAC brain?
A: Yes, through a SNAP PAC controller. groov does not access the brain directly; it works through a 
SNAP PAC controller running a PAC Control strategy.
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5: A: Appendix A

A: Extended Character Set

This appendix provides a list of the ASCII extended character set which you can use in gadget text 
when you are building an operator interface on a Windows PC. If you have a Mac, go to 
www.adobe.com/type/pdfs/characcessmac.pdf. To enter a character from this chart, hold down the 
ALT key and enter the number on the keypad. For example ALT+236 produces the infinity symbol, ∞.

Dec Sym Dec Sym Dec Sym Dec Sym Dec Sym Dec Sym Dec Sym Dec Sym

128 Ç 144 É 160 á 176 ░ 192 └ 208 ╨ 224 α 240 ≡
129 ü 145 æ 161 í 177 ▒ 193 ┴ 209 ╤ 225 ß 241 ±

130 é 146 Æ 162 ó 178 ▓ 194 ┬ 210 ╥ 226 Γ 242 ≥
131 â 147 ô 163 ú 179 │ 195 ├ 211 ╙ 227 π 243 ≤
132 ä 148 ö 164 ñ 180 ┤ 196 ─ 212 ╘ 228 Σ 244 ⌠
133 à 149 ò 165 Ñ 181 ╡ 197 ┼ 213 ╒ 229 σ 245 ⌡
134 å 150 û 166 ª 182 ╢ 198 ╞ 214 ╓ 230 µ 246 ÷

135 ç 151 ù 167 º 183 ╖ 199 ╟ 215 ╫ 231 τ 247 ≈
136 ê 152 ÿ 168 ¿ 184 ╕ 200 ╚ 216 ╪ 232 Φ 248 °

137 ë 153 Ö 169 ⌐ 185 ╣ 201 ╔ 217 ┘ 233 Θ 249 ·
138 è 154 Ü 170 ¬ 186 ║ 202 ╩ 218 ┌ 234 Ω 250 ·

139 ï 155 ¢ 171 ½ 187 ╗ 203 ╦ 219 █ 235 δ 251 √
140 î 156 £ 172 ¼ 188 ╝ 204 ╠ 220 ▄ 236 ∞ 252 ⁿ
141 ì 157 ¥ 173 ¡ 189 ╜ 205 ═ 221 ▌ 237 φ 253 ²

142 Ä 158 ₧ 174 « 190 ╛ 206 ╬ 222 ▐ 238 ε 254 ■
143 Å 159 ƒ 175 » 191 ┐ 207 ╧ 223 ▀ 239 ∩ 255  

http://www.adobe.com/type/pdfs/characcessmac.pdf
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6: A: AppTitleAppendix B

B: Network Cameras

The Video gadget works with IP cameras that can serve a single image in response to an http 
request without the need for an ActiveX control.

We have successfully used the following cameras in our projects:

• Foscam Fi8910w

• Foscam Fi9802w

• Vivotek FD8361

• Vivotek IP8352

If you are using a make or model camera other than ones listed here, you can try using one of the 
example URLs described in the sections below.
In this appendix:

Serving a Single Image in Response to an HTTP request............73
Setting up the Camera’s Username and Password.........................74
Foscam Cameras ............................................................................................74
Vivotek Cameras.............................................................................................75
Viewing a Camera Outside the Network.............................................75
Changing the Video Update Rate ..........................................................75

Serving a Single Image in Response to an HTTP request
groov does not support streaming. Instead it uses a web browser to grab a snapshot of what the 
camera is currently aimed at. Therefore, when you set up a Video gadget you cannot simply paste 
the camera’s IP address (like you can in your browser). Nor can you use the link that leads to the 
camera video stream. Instead you need to construct a link that will grab a snapshot of what your 
camera is currently aimed at. Your link will look something like this: 
http://123.123.123.123/snapshot.cgi

Every camera is different so you will have to look in your camera’s documentation to find out what 
your specific camera uses. It might be called either a snapshot or single shot.

TIP: To find URL information for your camera on the Internet, try doing a search using your camera model 
number and the word “snapshot.”
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Setting up the Camera’s Username and Password
If your camera requires a password, you will need to include the user name and password in the URL 
that the browser passes to the camera.

NOTE: Not all cameras use the same format, so you will need to refer to your camera’s documentation for 
the exact syntax. 

1. Construct the URL to include the user name and password.

For example:

http://123.123.123.123/snapshot.cgi?user=yourusername&pwd=yourpassword

Make sure to use your camera’s IP address and link information, and use the appropriate user 
name and password to replace yourusername and yourpassword. If you do not provide the user 
name and password in the URL, View will display an empty box instead of the image and 
prompt you for the user name and password.

NOTE: The link will not be secure because you are passing the username and password in plain text, 
so it is easy to sniff.

2. Open the URL in a new browser tab. 

You should see a static picture.

3. Try clicking Refresh or Reload in the browser.

If the static picture updates to a new picture, this means you’ve got a camera and a URL that 
will work with the groov app.

4. Copy and paste the URL into the video gadget, and then save the project.

In View the image is refreshed at the rate set in Configure > Project in groov Build.

NOTE: It is the browser that polls the camera, not the groov box. So the browser that needs to have 
network access, permissions, etc to access the camera, not the groov box.

If you use this procedure and cannot get the web browser to display a static image from the camera, 
it is not a groov issue. It is an issue with the camera itself or its configuration, the browser or browser 
settings, the network (e.g. not on same subnet), or network permissions.

Foscam Cameras

Foscam Fi8910w 
See foscam.us/products/foscam-fi8910w-wireless-ip-camera.html

Sample URL:
http://123.123.123.123/snapshot.cgi?user=opto&pwd=opto22

Change the IP address to match your internal or external IP address.

For example, if this camera were set up at Opto 22, the URL would be as follows;:
http://opto22.com/snapshot.cgi?usr=admin&pwd=masterpassword

Change the user and password (pwd) to match the configuration of your camera.

http://0.0.0.0/snapshot.cgi?user=yourusername&pwd=yourpassword
http://foscam.us/products/foscam-fi8910w-wireless-ip-camera.html/
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Foscam Fi9802w
See foscam.us/outdoor-cameras/foscam-fi9802w-wireless-ip-camera.html

Sample URL:

1. Change the IP address to match your internal or external IP address.
2. Change the user and password (pwd) to match the configuration of your camera.
3. If you are using a different port than port 80, you will need to add that to the URL.

For example, some Foscam cameras use port 88, so 88 is added to the URL as follows:

Vivotek Cameras
Cameras tested: 

• Vivotek FD8361

• Vivotek IP8352

For details on how to construct a URL for a Vivotek camera and configure security, see the 
documentation that came with the camera.

Example URL:

Here is an example of a URL to use with a Vivotek camera that is compatible with groov.

This camera is on port 8082, and it has been configured with a user viewer that has no username or 
password. Your camera may be configured differently.

Viewing a Camera Outside the Network
If you wish to view a camera image from outside your network, you need to ensure your camera can 
be accessed from outside the local area network it is configured on. Please discuss this with your IT 
department to set up a VPN or allow a port forward on your router to the camera.

CAUTION: Be aware that anyone with access to groov Build can view the username and password to the 
camera in clear text. This should be accounted for when setting up access to groov Build and access to the 
camera.

Changing the Video Update Rate
To change the rate that groov updates the video feed, in Build go to Configure > Project to open the 
Project Settings dialog box. The Video Update Period determines how often in seconds a video 

http://123.123.123.123/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=opto&pwd=opto22

http://123.123.123.123:88/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=opto&pwd=opto22

http://opto22.groov.com:8082/cgi-bin/viewer/video.jpg?channel=1&resolution=640x480&quality=3

http://foscam.us/outdoor-cameras/foscam-fi9802w-wireless-ip-camera.html
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gadget will update the video feed. The default is 0.5 seconds, the fastest setting possible. The Video 
Update Period applies to all video feeds in your groov project. 

If you have a fast Internet connection and are not concerned about data use, then you can use the 
fast setting (0.5 seconds) for a smoother video. However, if you have slower connection, the video 
might not be able to keep up, and you should back off the rate by entering a bigger value. Also, if 
you have a data use cap, you should probably back off the rate.

Satellite or cell modem networks may require refresh rates of 5 seconds or slower. For example, the 
default 0.5 seconds may be too fast for some ADSL connections.
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A
Android

operating system, 64
smartphone, 64

apps for mobile devices, 4

B
back up

project, 48
browsers, 5
Button gadget, 32

C
category
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delete, 13
rename, 13

Checkbox gadget, 32
Chrome, 5
Command Button gadget, 33
controller

add, 14
CSS3, 5

D
Divider gadget, 30
drag page, 14

F
FactoryFloor, 69
Firefox, 5

G
gadget

Button, 32
change Z order, 38
change z order, 39
Checkbox, 32
Command Button, 33
cut and paste, 38
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Group Header, 29
Horizontal Gauge, 34
Horizontal Slider, 33
Image, 31
LED, 31
Line Header, 30
Page Navigator, 30
Plot, 38
Range Indicator, 37
Round Gauge, 36
Text Area, 34
Text Input, 35
Value, 35
Video, 31

groov Find, 61
groov View

Android, 4
groov View for

iOS, 4
Group Header gadget, 29

H
HDTV, 5
help

Opto 22 Product Support, 7
Product Support, 7

Horizontal Gauge gadget, 34
Horizontal Slider gadget, 33
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HTML5, 5

I
Image gadget, 31
Increase Height button, 12
iOS operating system, 64

L
layouts, 40
LED

gadget, 31
license

updating, 49
Line Header gadget, 30
Linux computer, 64

M
Mac, 64
maintenance

expiration data, 49
update, 49

mobile devices, 4
move page, 14
MS Surface, 64

N
Namespace Index, 21

O
OPC-UA server, 16
Opto 22 Product Support

contacting, 7
OptoEMU Sensor, 69

P
page

add, 11
delete, 13
duplicate, 14
rename, 13
resize, 12

Page Navigator gadget, 30
password

change, View, 46
user

account, 45
View, 53

Plot gadget, 38
project

back up, 48
settings, 47

R
Range Indicator gadget, 37
Round Gauge gadget, 36

S
screen size, 64
security

level, 42, 65
static IP address, 11
strategy

.idb.txt file, 68
add, 15
update, 16

SVG, 5

T
tag server, 16
Technical Support. See Opto 22 Product Support, 7
Text Area gadget, 34
Text Input gadget, 35
troubleshooting

Opto 22 Product Support, 7

U
user

account
delete, 45, 46
password, 45

create, 42
groups, 44
security level, 42

User Account Control, 61

V
Value gadget, 35
Video gadget, 31
video refresh rate, 47
Video Update Period, 47
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